Group or Component Bounding Box Issue

boundingbox

#1

In Sketchup 2018 I noticed an issue with the dotted bounding box of groups or components where one or more edges seem to appear as a line rather than dots. It’s a minor problem, but kind of annoying since I keep thinking I have stray lines in my model.

Already tried changing OpenGL antiliasing to different settings, from 0x to 8x, which didn’t work.

Might be a graphics card issue, although I have a new decent Quadro card and I never had this problem in Sketchup 2017.

Just curious if anyone else experienced this?


#2

I’ve not seen the bounding box looking solid.

Could you share the SKP file so we can take a look at the same file you’re looking at for this?


#3

See attached file. Don’t orbit straight away, just double click to open the group and see if it’s happening. If you don’t notice the same problem, maybe orbit around with the group open and see if it happens. I only notice it in certain viewing angles. Thanks for taking a look.

Bounding Box Issue.skp (103.5 KB)


#4

I can see it, but it’s probably caused by the size of the component. Scale it down somewhat and it goes away.


#5

Ah, ok I wondered if unit tolerance or something might be the issue… hmm. I’m also noticing weird ghosting problems with bounding box edges. I know this is supposed to happen for the backside edges on the bounding box, but now it’s ghosting on the edges facing the camera too sometimes… not sure what’s happening.


#6

Moving the model back to the origin seems to have fixed the bounding box issue without changing the scale of the model.


#7

I can see the edit bounding box effect too. Editing the style to use a white background and turn off the sky seems to help a bit, but some edges of the box are noticeably fainter than others even then. Seems like an artifact of the way the edge stippling is generated in OpenGL?


#8

Ok, ya I wondered if that might be the case, but didn’t think this was too far from the origin for that to be an issue. Unfortunately this is part of a much bigger model that is already positioned at the origin, so moving it will only move other elements further away. Ok, good to know and thanks for checking!


#9

Just a note, here you can see I duplicate the issue by scaling up the component at the origin. Personally I don’t see it as a problem, just the way open gl works.
BoundingIssue


#10

setting the multisample in the Window>Preferences>OpenGL to a lower level seems to have an impact


#11

Probably, but for me, I don’t see it as an issue worth worrying about.


#12

Ya it really is a minor thing… just wanted to mention it since it’s the first I’ve noticed it and at first I kept trying to erase the line thinking it was something in the model. No big deal though.


#13

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.