Help, my arc and circles have gone crazy

arc

I’m using Make 2017 and have received a file exported from Rhino. It was in Arch imperial units and I changed units to mm, with no issue.

However now everytime I try to work with info that’s touched that file (even cut and pasted into a new file) it exhibits a kind of resolution issue where my circles and arcs just pixelate into a mess of angles. I also get flickering of intersecting faces and stuff that suggests to me that this is a resolution type issue. Like it’s expecting a model 1000 times the size and doesn’t want me working on the head of a pin.

I’ve tried to purge, fix problems, cut and paste, reset etc. but i really need to be able to trace over this stuff from Rhino in a useable way.

What am I missing, I’m sure this should be easily fixed.

Cheers

CG

Sounds like the origin of the import is a long way away.
Can you explode the import then regoup it.

That’s just the sort of advice I needed… I’ll try it now. :grinning:

Should I explode then use the “move origin” command then regroup it with an origin close to the model?

Is the axis visible in the model? If so just explode and regroup, this should remove any geolocation info from the import.
You can attach the model if you want us to check it.

Thanks Box,

I can’t seem to attach the file as it’s 20 meg

Just trying your advice now… but exploding is causing me lots of crashes, which is part of the reason why I just wanted to trace over the ■■■■ mess and bin it in the first place.

Excuse me as I come from AutoCAD and MAX background with their relatively fixed 0,0,0 origin and so still haven’t completely gotten my head around SU’s origin :slight_smile:

What was the file you imported?
Did you adjust the options on the import dialog, one being ‘Maintain origin’ or words to that effect, which you don’t want to choose?
You could upload the file to dropbox or similar and add a link here.

This was exported by a third party so I didn’t see any options they used. However just an explode (finally) and re-group has worked perfectly so many thanks for your invaluable help :grinning:

The options I mean are a button on the Import dialog, for future reference.
Glad you go it sorted though.

Actually I may have spoken too soon… my arcs and circles still behave weirdly.

I’ll upload a link now for you to have a look if that’s not too much trouble.

Does that work?

Opening it now

First go View/Edges Styles and turn off profiles
Then select the model and group it.
Then get the move tool and start to move it roughly in the direction of the origin,
let go of the mouse and type [0,0,0] and hit enter.
Then hit shift+z
This will move it back to the origin and you can start to work on it there.

Thanks so much, that’s worked much better this time.

So I understand what I’ve done there - why turn off profiles? and can I use the square brackets and actual co-ordinates in general use as this would help me orient things (in my head and in SU :stuck_out_tongue: )

Cheers

CG

Profile just make the model heavier, you can turn them on again if you want but they tend to make things lag.
Yes the square brackets are absolute, no brackets and it will move in those three directions from where it is.

Thanks… I just got to like SU a bit more :slight_smile:

1 Like

Just one quick question that leads from this… how do I interrogate SU to tell me the absolute coordinates of a particular point, an endpoint or centre of a circle?

There is a utility that you can download for it, but the Text tool will do it. The icon with the A1 and the arrow when click on a point will give the position.

Edit: I added the Utilities Tool from the extension warehouse and yes the Query Tool does work in 2021. It is handy as it will display info on all sorts of things but the text tag can be better as you can label the point making it easier to see what you want to type in, although there needs to be a vertex.

Illustrating what Box indicated about using the Text tool. It only gives coordinates for endpoints so you may need to temporarily explode a circle or you may need to add a short line segment as I did in this example.

Awesome thanks guys. I’ll check those out. :slight_smile:

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.