HELP - I'm unable to display shadows on the ground in Sketchup

I think I have all the right settings to display shadows on the ground but for some reason it does not work. Any ideas as to how I can fix this? Thanks.
Playhouse.skp (6.2 MB)

Change UTC

Thanks! That works, but any idea why some time zones would fail to display shadows? Ideally I would like to work with the real UTC where I am located.

Your geo-location and time zone must match. The “not geolocated” setting places the model, in fact, in Boulder, Colorado.

Thanks!