Help can not launch sketchup

Check the requirements of your games, most if not all rely on DirectX - not OpenGL. On top of that, SU requires more OpenGL function calls than what other programs require. Driver developers may leave out some function calls if most of their card users tend not to run programs that require such things and/or the card isn’t able to support them for some reason.

Most SU-users have Nvidia cards as the drivers are more complete and thus better support SU requirements. The cheaper AMD radeon cards are geared more for gamers.

Updating drivers is basic computer maintenance - it shouldn’t be too bothersome. AMD does have an autodetect tool to make finding drivers more pleasant. If there is an issue updating drivers, it may be wise to uninstall the old driver and reboot the computer before installing the new driver to ensure the old stuff is flushed out.

Any progress on updating the card driver or try disabling hardware accerleration with sketch3d_de’s OpenGL utility?

1 Like

I looked this report up in our Bugsplat reports and have to say, it’s a new one… we’ve only had a whopping 5 reports of this and 4 of them are @br1zzl3 which sadly means there isn’t a good view of what’s happening. I see some references to ATI drivers, but also note that the Template Picker is using Internet Explorer and might be at fault as well.

Did you ever run SketchUp 2015 or is this your first installation of SketchUp ever? I see a bunch of Linux chatter in here, but want to clarify that you’re not running Windows 7 in any virtualized manner, this is Windows 7 installed natively on a computer yes?

No I run Ubuntu 15.10 as the laptops Operating system and installed Virtual Box to put windows in and it was win 7-1 And i did run 2015 before I switched to 2016 . . I use the sketchup Make version as i am one of the poor people living on Social Security and got a 3D printer for a business to make money some day . .
But then I have a I3 quad core 2.4 gigaherts and 16 gig of DDR3 can run most any thing with it . .
A lot of the people here do use Windows as a base operating system and I have fun watching the messages i get saying this graphic card or this file will not load, , NEVER have that on mine YET !

@lynne That question wasn’t directed at you, please stop adding irrelevant off topic posts.


Yes Lynne, my question was directed at @br1zzl3 and unfortunately your Linux enthusiasm is just confusing this topic. I’m glad you like Linux, but you’re wholly on your own in that area as we don’t support it or encourage it. Please keep allow this thread to remain on topic without further unrelated posts.



this is my first install and the linux chatter was something that was
suggested to me i have windows 7

Lovely, this problem is relatively unique out of millions of users…

Bringing up the part of IE being used at the template picking stage brings the need to give IE a little TLC. Program developers use tools provided by the OS developer. So no matter what a computer user sets as their preferred browser, programs use the default OS browser: in Windows, that’s IE.

The first two things to maintain IE is update it to the latest version and clear it’s cookies and cache. Believe it or not, it’s possible for IE to accumulate a significantly larger cache than your default browser.

The other burden of relying on the OS provided browser, specifically IE, is that they handle all network security and proxies through that browser rather than a setting at the OS level. While it might not apply to this particular problem, it is also important to set Internet Explorer to “Moderate” security settings and to disable Protected Mode, both of which will restrict Javascript usage which SketchUp needs.

@br1zzl3 You can go to Internet Options within Internet Explorer, then Security and set the slider to Medium and Uncheck the box for Protected Mode then try SketchUp again and let me know how that works out. (Also please confirm which version of Internet Explorer and upgrade to the latest non-beta version if you’re not already there.)

I look forward to your response.

i have updated ie and set the setting where you have told me and still go
the bug splat i dont know if they are the same or not but i sent them anyway

The 3 main causes of start up splats are graphic driver, extensions (like V-ray), and IE. Did you check for update of your graphic driver?

If the driver is up-to-date, many AMD users are able to work with older drivers. See Is anyone successfully using Latest AMD Radeon "Crimson" driver with Sketchup 2016 - #6 by SketchUp3D_de.