Help! All my front faces went transparent!

I imported a model from the 3D warehouse and then somehow all my front faces are transparent/gone.

It’s particularly bizarre, because when I do X-Ray mode, I can see a transparency of the front face (see the wood paneling on the gate around the house). But when I remove X-Ray mode, it disappears from view entirely.

Pictures below. Please help!

Have you checked your face orientations?

Verify if somehow the imported model is located very far from the point of origin 0,0,0

Post the model here to get the best advice.

Change the camera to perspective, any change? Then hit zoom extents, any change? Delete the last thing you imported, any change?

Tried googling it and trying different things to different faces. Didn’t do much. :frowning:

Different attempts to change camera and delete/undo didn’t work. I must have hit something and then screwed up my view/settings; don’t know what.

That said, I copied all and pasted into a new model. It “fixed” the problem, but I still don’t know what the original issue was.

Without seeing the model we can only guess and without knowing what is causing it you may well keep doing it.

What happens when you do a Zoom Extents? Did your import bring in some geometry that is very far from the model origin?