Help aligning 3D model with axis


#1

I downloaded a very nicely made 3D model from the 3D Workshop, but unfortunately it came unaligned to the red axis. It was in a group, so the group box was aligned perfectly but the actual piece was a bit off the axis. I only noticed this problem when I tried to cut off half of it to modify it and then reflect it and put it back into one piece

Here’s what it looks like when I flip and paste the two pieces together. Notice the red axis line in this picture

I’ve tried a few plug ins, none of them really did what I wanted, but I’m willing to try any plugins. Thanks for any help


#2

It would help if you gave us the warehouse link for the specific model, but, no plugins needed, use Change Axes from the context menu of a component.

I’ve done it here using a cube, so it’s more simple than what you’ll need to do but the process is the same.
You need to determine where the axes need to be on your model and place them there.

As you can see here, first I right click and select Make Component, then right click again and select Change Axes, then three clicks to place the axes. Then reinsert the component from the component window and it will be as you have aligned it.


#3

Might you be equally willing to try any learning resources available to you?
Honestly, @Altair, the very notion one needs a plugin to orient geometry precisely is absurd.
All one needs is a bit of enlightenment and practice with SketchUp’s native tools.
Start with these and then feel free to ask followup questions:


Inference Types — SketchUp Help

Tweaking Tool Tips — SketchUp Sage Tutorials


Rotate


Move


#4

@Box Thank you, I already knew where the axis for the model was so this did the job perfectly well

@Geo Thanks for the tips, I already knew how to use rotate (It wasn’t what I had to use because the angle of the item’s axis wasn’t at a degree that was just a notch or two away from the correct axis), but I am very new to this software. I’ve learned how to make most shapes and I’m faring pretty well with doing 3D models, but some tools are still a mystery to me. I hope I’m using the correct terminology to explain why I couldn’t use the rotate tool