Axis Alignment When Importing Things

This is a topic that has always confused me and frustrated me. I am importing a Fusion 360 component and cant not for the life of me figure out the best way to get it to align to the xyz axis in a way that makes sense. I have looked on YouTube and watched some videos. I have looked at some 3D warehouse addins, etc. I have also seen things like you can’t permanently save axis changes. I must be making this harder than it has to be. If it helps I have attached the Sketchup file and also a screenshot. Any suggestions on how to accomplish this quickly? I have tried rotation and movement and it still looks wonky. Specifically, when I use the built-in camera views they do not produce what I think they should.
Planter_v1.skp (1.9 MB)

What file type are you using to export from F360?

I am actually exporting a Sketchup 2020 file. I didn’t like the built-in export from Fusion 360 so I am using the Sim-Labs plugin which seems to work great. It actually keeps all of the components where as the built-in one from Fusion 360 exported it as one big component for Sketchup files. I also tried STL and that didn’t work any better.

I guess I would start by looking at which orientation you’re creating the model in to begin with. Make sure the Z-axis is up. I see a lot of things modeled in CAD programs like F360 and OnShape where the user doesn’t seem to be aware of this axis is up. and when they go to use that object in another file, they have to spend time rotating the object to get it into the correct orientation.

Are there any options in the exporter for choosing the axis orientation?

If it continues to be a struggle, it’s not terribly difficult to rotate the model using the Move tool. I rotated it in a couple of seconds so what I presume is the front is parallel to the red axis.

Out of curiosity is there are reason not to just model it in Sketchup from the beginning? Looking at your model I find the way the components are created to be kind of inefficient. For example here you have what ought to be four instances of the same component as four different components.

And interestingly, their surfaces are in close formation with each other but not actually touching. Solid Inspector 2 identifies the perimeters of the surfaces as surface borders because of this.

Triple clicking on any geometry in the component should select all of the geometry but it doesn’t in your model.

I see this in all of the components in your model. Also, curiously, each of the slats on the side is a component inside of a group.

This things will just make the model more difficult to work with in SketchUp.

1 Like

I have used Sketchup for many years and have a perpetual license for 2020. When they did away with it and went to a subscription model I started looking at alternatives. The free version of Fusion 360 works great for what I need and want. For me for woodworking it actually works better. I am bringing it into Sketchup to use Layout to produce the plans. The only limitation that the free version of F360 that impacts me is 1 document and you could have one print it and archive it create a new one etc. In F360 there are only a few components there are not 4 legs only one that is mirrored I imagine the having 4 components is just the way that Simlabs exports it. So the things like selecting surfaces and it not selecting everything I am sure is a by product of the export. Again when readying things for Layout the big issue was when I switch from say ISO to front or back it does not show the view I expect (or the same view I see in F360) so I was trying to understand why that is. Your version which you created from scratch shows the views I would expect when moving between different views.

OK. Whatever works for you.

As for the standard views in SketchUp, they are fixed. With the default global axis orientation the standard front view will be with the red axis running horizontally across the screen. As I suggested, you’ll need to make sure you have the model oriented correctly in F360 or check to see that the importer handles the axes correctly.

It is modeled and views correctly in F360 I will have to look again to see if you can control the axis in export I didn’t see that option but will look again. If I could get the alignment to produce the standard views in Sketchup I would be set (but not modeling it again from scratch). I will keep plugging on.

Good luck. I find it interesting that cutlist from your F360 model in SU looks like this.


I redrew it as I would have modeled it directly in SU and got this.

I reached out to simlabs and asked the question. It turns out that you can set the export axis. I modeled in F360 with z up but when I export I had to changed to Y+ up now it comes into Sketchup like I would expect and all standard views work fine now. Hopefully this will help anyone else that runs into this.

Good enough. Is there an obvious Options thing in the exporter?

Its not in the export dialog only the version of Sketchup you want to target. It is a setting that you can update and it is easy to find.