Having trouble with shadows when rendering in Podium

Hello, please bare with me because i’m a student and having big issues with shadows in my sketchup model. I’m trying to get accurate shadows for my Final Scene 1 and 2, but every time I turn them on the room goes dark, it seems my shadows only work when there is no roof on the room. I can’t get shadows cast from my windows or sunlight coming through. Please help :frowning: I cant upload the skp file as it is too large but there is two jpg of when I render it in podium without the roof

Upload the file to wetransfer.

You say in your profile you have no graphics card. That might affect things.
If you’re unsure, just go into Device Manager. Under Display Adapters, what’s there?

Is this actually in a render? If so, which renderer?

1 Like

This is done in Podium

1 Like

Thank you, I believe mine is ADM Radeon R7 240 series

1 Like

This is the wetransfer link, thank you so much for your help.

I’m downloading something at the moment. My Wi-fi isn’t happy with 2 files. I’ll try and get to it once it’s done if someone doesn’t beat me to it.

No problem, thank you nonetheless. I appreciate your time and effort :slight_smile:

1 Like

It doesn’t look like you’ve added any lights from what I can see.

If you turn on the Shadows in the model it’ll be dark due to the UTC offset in Shadows and the longitude you have in Model Info>Geo-Location. Try changing the UTC offset to something like -03:00.

It was fun trying to rescue something from the dark image.

I am only trying to get natural sunlight through the windows, I will change the UTC, thank you! :slight_smile:

That is what I just got too :frowning:

Keep in mind it will be fairly dark in the model, then, unless your windows are allow to burn out.

In Final Scene 1 it’s going to be very dark because the windows are on the north side so there’ll be no light entering the windows.

1 Like

Okay, Thank you. I was able to get good lighting in #2, but #1 is super yellow.


Still I can only get this image without a roof lol

I’m not sure what you are expecting will happen. The windows are on the side of the building away from the sun and you have nothing outside the windows to reflect light into the room. With the roof on you just aren’t going to get any light in.

As for the color, It looks like reflection. The sun color is probably set to be warm anyway and then things like the wood floor and the bedside tables will warm up the reflections.

Well, thank you. I rotated my model and it seems to have fixed things.

Yes. That would make it possible for the sun to shine in the windows.

FWIW, you should get into the habit of proper tag usage. Here I fixed the incorrect tag use be removing tags from edges and faces.
Screenshot - 2_23_2022 , 1_11_06 PM

Also it’s a food idea to purge unused stuff. this reduced file size by almost 45% and makes the model easier to work with.
Screenshot - 2_23_2022 , 1_11_37 PM

I think you could make your file even easier to manage if you put some of your components on diets. There’s nearly 14,000 entities in the napkins on the table. That’s a bit excessive for just a napkin.

The position of the sun in the world won’t let you have shadows in this room : try using the add location option to place the building in the place where it might be. You can rotate the sun around the model with “solar north”

Mostly to lighten it up you can use the bright interior presents and maybe increase the sky intensity and exposure a little too

1 Like

Thank you so much! I’ll remember this for future projects. :slight_smile: