Having trouble making ramp shape

I have a relatively simple shape (a rectangle with an arc cut out of one side) and I want to lower the front edge so that it makes a ramp-like shape.

The problem is that it doesn’t seem to be handling some of the curving the way I expected it to. It seems to use a flatter plane for one section of the inclined area but a nice curve for the rest.

To lower the front edge, I am selecting the edge and pulling it down with the move tool.

In the file I show the model before and after I do this step. Does anyone know how I can avoid this?

ramp.skp (75.6 KB)

Try this: Rotate the top face about the red (X) axis

to get this:

Then delete the extra line that’s created:

You can use R-click/Erase, use the Eraser tool, or highlight the line and tap the Delete key (Backspace on Mac).

End result, this:

But the back, curved, face is no longer vertical.

If that matters, you need a different approach.

Make your original ramp into a (temporary) component.

Draw a rectangle (not inside the component, but outside it) on the top plane, bigger than it.

Rotate the rectangle down to the front corner.

Explode the component.

Select all, then Intersect Faces/With selection, and clean up the overlaps.

Does one of these do what you want?

5 Likes

You have definitely given me enough to play with! Thank you so much!

1 Like

Here’s another option for you, note the little cross that appears with the pushpull tool, that is done using ctrl (I think Option on Mac), this will allow the pushpull to go through the curve.
Wedge

7 Likes

@Box @john_mcclenahan thank you both for the great suggestions!

For this model I did want to keep the arc at the top level after the incline is added. I think this makes the curve more complex. Do you think it is too complex for SketchUp? Do I need a plugin for this?

Here’s another model with a more complex shape that resembles a 360 degree version of this ramp. Same as before, I’m trying to make an irregular bevel around a complex shape, and SketchUp adds strange lines.

Any ideas how to approach this?

ramp360.skp (77.7 KB)

1 Like

Sketchup needs to break up the faces to create the ‘slope/bend’ it doesn’t always get it right. Often it is best to create the divisions first.
Here I use split tools from Tig at sketchucation to split the face of the ring, then weld the edge back together and away you go.
Donut
You can do it manually too.

4 Likes

In the same way, dividing the face will help.
Ramp

5 Likes

Ahha! That looks perfect! I’m going to give that a try right now. Thank you! :muscle:

In this one did you divide the face manually? Would you just draw lines to do that?

The erasing surprised me. Do the line divisions affect the shape even after being erased? Is the smooth erase option important here?

I am learning a lot! Thank you so much for your help :pray:

I did draw them manually, but I didn’t erase them, I used the eraser tool with ctrl to soften them.

3 Likes

Mind blown! Thanks again.

Everybody seems to have forgotten the Sandbox from Contours tool:

6 Likes

Thank you for suggesting this! I am getting some wild results with that technique though.

You should not get bad results from Sandbox. You only want to select the edges bounding the top surface. You will probably get the faces filling in inside of the arc where you don’t want it. just erase that part afterwards.

1 Like

@pbacot @Anssi you guys were right! When I used the sandbox tool properly it worked very well. Thank you everyone!

Yet another solution: Solid Tools.

Thank you! Yeah I played around with this technique a bit, but I wasn’t able to keep the top of the arc level. Instead the arc follows the ramp’s face downwards.

Create the arc shape from the bottom, or before you make the ramp.

Does that produce a level arc? Your screenshot shows a slanted arc down the ramp. I think creating the arc from the bottom or before will still result in this.

I misunderstood.