Grouping of "Select All" missing disabled edges

I am unable to group all the drawing elements in the model when “View…Hidden Geometry” is enabled.

An example model is an ungrouped cube with a simple edge line off to the side. With “View…Edge Style…Edge” disabled the edges of course are hidden. Performing a select all results in the cube faces (and associated edges) being selected, but not the loose edge. Grouping the selection results in omission of the loose edge missing from the group. A simple “View…Hidden Geometry” doesn’t fix it as the edges remain hidden.

The solution is to enable edges prior to select all. Is this correct behavior?

Yes - you don’t want to select anything you can’t see. You will find the same thing happens for hidden geometry and things on hidden layers.

On the flip side, you can change the view mode to “wireframe” and select all, group and you will have all the edges and no fills.

Both are handy things to know sometimes.