Grey screen of death

I’ve been building a model in the free version of Sketchup on the web. (Chrome on macOS Mojave.) No issues, worked great. All of a sudden, the screen’s grey—no horizon, no axes, no parts, nothing. Seconds later, it auto-saved, and now nothing seems to jackhammer it back into life. I’ve restarted both Chrome and the Mac, and I can re-open the saved file, but it’s still the grey screen of death.

Other posts on this forum and articles that I’ve found online all seem to relate to the Sketchup Pro app rather than the web version. One talks about a Time-Machine-like version history, which would be great, but I can’t find anything like that in the web version; same goes for suggestions to change the graphics card prefs. (Which would seem odd anyway since it was working fine right up until the moment it wasn’t, and it didn’t stop working right after I told it to add a bazillion faces or anything.)

The most promising one that I found was from this January, but the advice there (“Select them in Outliner and erase them from there. After that, purge unused from Model Info>Statistics. I purged the unused stuff from your model and got rid of the following”) also seems related to the Pro app.

Is there anything I can do in the web app to resuscitate the model?

Have you tried Zoom Extents?

Can you upload the model so we can see what you have going on?

Thanks for the swift reply, that’s awesome; zoom extents is shift and Z, correct? Yes, I’ve tried that, and it doesn’t change the view. Interestingly, it’s not actually locked up; I can select different tools, they just don’t do anything.

And in testing ZE, I just noticed that the screen isn’t entirely blank: There’s a dotted vertical line, and if I choose the select tool, I can select it (turns from blue dots to black).

I downloaded an SKP file of it, and can share that if necessary, but I’d rather not put the whole model in a public link (proprietary issues) if avoidable. Edit: Link sent by PM.

Well, there appears to be 86,080 entities and not a single component or group. I selected all and copied it into a new file and put it close to the origin. I see this. Is it what you expect to see?
Screenshot%20-%208_8_2019%20%2C%209_52_06%20AM

It’s unfortunate that it’s all loose geometry. That will make it hard to work on.

1 Like

Yes, that looks correct. I’m entirely a newbie, so components and grouping aren’t things I know about, I’m afraid. (If memory serves, the original origin was immediately below the hexagonal nut at the center.) It’s reassuring that it isn’t lost; what steps should I take?

I’ll share the link in a PM.

You really ought to take some time to learn the basics of SketchUp. Groups and Components are very important. As it is, your model is built as if the entire thing has been whittle out of one big hunk of material. Groups and components are the way to keep things separated.
Screenshot%20-%208_8_2019%20%2C%2010_07_57%20AM
If things like tooth profiles and correct meshing are important, you might find a desktop version of SketchUp to be more suitable because there are extensions that can be used to draw proper gears. And of course if this is for some non-hooby use, you need to be using SketchUp Pro anyway.

1 Like

Everything looks intact, which is great, thanks so much!

The only thing that looks “wrong” is the main rotor is missing its top; I’m not sure if that sheds light on what happened? For the reference of future forum readers with this issue (quite a frightening one when it happens), is there any indication as to what went wrong?

As much as I’ve enjoyed working on this in Sketchup, this is the first model I’ve built in it and I don’t anticipate needing to build others. (Although it will now be my first-port-of-call for such things—excellent program, and excellent support, too.) I of course 100% agree with what you’re saying, and by analogy to thing like Photoshop, yes, of course; if I were planning other uses, I would definitely want to do that.

It’s hard to say why that face got deleted. There are some other faces missing as well. Could be due to erasing some needed edge.

Unfortunately I can’t identify what went wrong in your model to cause the thing to “disappear.” We’ve seen some cases in which the user deletes an entity with a label attached to it without also deleting the label. The text winds uphundreds of miles from the rest of the model and that causes a problem. I didn’t find any text in your file at all, though.

1 Like

Okay. Well, I’m very grateful that you were able to extract and re-compile it, so-to-speak. I can rebuild the (very few) missing elements, I just wondered whether there was something diagnostically-helpful to take from their disappearance. :slight_smile:

As an aside, it’s worth noting that the gears don’t have to mesh perfectly for my purposes; it’s going to be photographed not built. On the “hero” elements that’ll be nearer the camera, the gears are calculated and (hopefully) more-or-less correct, but on elements that’ll be farther away and slightly out-of-focus, I’ve not worried too much about getting them more than basically right.

1 Like