Grayed out toolbar

Well, I couldn’t figure out how to introduce myself, but I signed up. Intermediate user, professional, mostly timber frame design and shop drawings sometimes turn key residential work.

I have a question. After doing a photo match my standard views palette in the tool bar is grayed out and not functional. That happened to my layers window earlier too. Can still get the views by going to top bar/camera/standard views but that is frustrating.

What is happening here?

@TJoshua, the standard views and other toolbars will be grayed out while the MatchPhoto dialog is active. Once you click Done in the Match Photo window, however, the toolbars should return to being active.

That makes sense, but I’ve tried again with a model where the first photo match worked OK, then when I match a second photo and say “done” my style palette is gray and locked along with layers palette and standard palette in top menu bar.

Heya @TJoshua,

Just wanted to let you know that I peeled this topic off the SketchUp Sages thread into a unique thread since this conversation has steered into a focused discussion on the issue you’re seeing. Please ensure that your replies are going to this thread.


Weird. I just tried importing a second image and after clicking Done, the tool palettes come back as expected.

Hmm. The simple fix of quit and restart sketchup seems to have resolved it for me too. Thanks!

Sounds like something you’d get from Windows tech support. :smiley: Glad it worked, though.

I realize this is an old topic, but thought that I’d add that after messing around with match photo, half of my tools are grayed out. Have not ever had this problem.

I used the match photo tool and clicked done, then clicked the “cogs” in the top to reopen the grid to make some adjustments. It was after that that the tools were grayed out. I now have match photo completely closed but still have grayed out tools. I will restart and that will probably fix it, but thought I’d point out a potential issue.

I use both Mac and Windows, but this occurred on the mac version.

Only certain extensions are grayed out.

This may or may not be related to match photo, but there was a short time when Fredo’s Lib caused a gray menu issue, check that you have his most up to date version.

Box makes a good point. Fredo6 had introduced a problem in LibFredo6 which would result in some menu items. That was in a version from last November. He did fix it toward the end of November. Easy enough to update to the current version to make sure.

Will do, thanks