Google imagery imports blank


#1

There was another thread related to this issue but no clear answer. Using Sketchup Pro 2016 (tried my 2015 as well) on a brand new iMac running OSX 10.11.3.

When I use add google location to import imagery to my Sketchup model it allows me to view the location and select the region but imports a blank white rectangle and does not display the imagery. I have tried several times and have restarted and run nothing but Skecthup to no avail. I am sure that textures with shading is on so it’s not a texture issue. Any ideas?


#2

Well, same version, works here. When you click on “Grab”, does the window resize to the exact size of your selection region? Can you double click on the blank white rectangle, and unlock the layer? Did you get terrain?


#3

I can view the imagery in the add terrain window, I can slect the region to grab (large or small doesn’t matter) and I can hit grab. It adds the shape for the imagery and it even adds the terrain just not the actual imagery. I simply get a white rectangle. I have made sure that textures are on and even tried SU 2015 with the same result…


#4

I should say also that I have used this tool many times over several versions and had no issue at all.


#5

That would imply that you’re getting data, but it’s just not applying the image. I’d do a thorough cache-cleaning, which on Mac’s these days takes a bit of doing:

0.5 Close SketchUp

  1. Clear Safari cache.
  2. Clear SketchUp application cache: in Finder, cmd-g and go to ~/Library/Caches/, and remove directory “com.sketchup.SketchUp.2016”.
  3. Clear SketchUp application saved state: in Finder, cmd-g and go to ~/Library/Saved Application State/, and remove directory “com.sketchup.SketchUp.2016.savedState”.

But that’s not good enough: Apple caches plist info using Core Foundation Preferences daemon, so you have to kill that daemon and let it restart, or log out and back in. To kill it without logging out, open terminal and type
"killall cfprefsd", hit enter, and the daemon should stop and restart, emptying it’s cache. Then restart SketchUp and retry.


#6

Thanks for the ideas. I tried this process twice to no avail. All caches were cleared. Only issue was that The folder for Clear SketchUp application saved state was not there (the sketchup folder did not exist). Every other step followed. Issue still persists.


#7

There are spaces in that name, so make sure you can navigate through them. If you cmd-g and just go to ~/Library, you can navigate to it.


#8

No I mean I can get to the user folder/library/Saved Application State folder but the directory “com.sketchup.SketchUp.2016.savedState” did not exist there.


#9

I see it now - app has to be open for it to exist. I will try again…


#10

Still not working. Tried the process to the letter twice more and still blank. I also noticed if it’s helpful that even after the cache clearing that when I use the add imagery button it remembers the exact location and zoom level from previous attempts…


#11

That’s stored in a cookie. If you really want to clear that, I can show you how via a defaults write and some developer tool wrangling. I think it only lasts for a day, so that if you come back before midnight, it remembers, and then starts again tomorrow.


#12

A post was split to a new topic: Geo Location on 2017