Add Location on Mac showing empty images


#1

@Barry, I was just checking this on my mac, and Add Location is bringing in empty images…

everything appears to function, but after the grab, there are the two new layers and there is terrain, but neither has the image attached…

when I tried to re-grab I had a bugsplat [john@drivenupthewall]

Warehouse is functioning fine…
as is Photo Textures on the same model…
john


Select/Grab button on Add location dialog box not working
#2

Checking crash stack. Wow, it got a notification for a mouseMove, then threw an objc_msgsend:

com.apple.WebKitLegacy!WebChromeClient::mouseDidMoveOverElement

So something wacked with Safari - clear cache, reload both Safari & SketchUp, and retry. What Safari version?


#3

@Barry, here’s the debug info, everything else is working…
I’ll clear the SU webkit cache, as Safari’s has no effect…

Debugging Information

User Info:	
Name	John
Email	john.drivenupthewall@googlemail.com
Server Info:	
Branch	deploy-2015-08-12
Build Date	2015-08-26 21:47
Commit ID	7ad841ee1acdab392001f0e38760cf8ac2bc87ea
Last Commit Date	2015-08-25 10:44
Client Info:	
User Agent	Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/600.8.9 (KHTML, like Gecko) SketchUp/15.3 (Mac; Safari)
Mac OS X	10.10
SketchUp	15.3
WebGL Enabled	true
File API Enabled	true
IE8 Enabled	false
Mobile Enabled	false
Cookies Enabled	true
Cookies	__utma = 201286956.485155500.1393455974.1398794487.1398881175.15
_dc_gtm_UA-51167241-1 = 1
_ga = GA1.3.1506711985.1346846745
_gat_UA-51167241-1 = 1
3dw_ticket = 95c1290288136e2356361ccd4c2a1969d5c3ab1c
hasDismissedTos2015Pointer = 1
hl = en
lastAddress = 
lastMarker = 
lastView = 51.45183972922175,-0.07276171717932378,21
searchBarSearchType = entity
sketchUpType = pro
__asc = bcfb1f9e14f70a66bfd9bd2ff6e
__auc = 714c3a8b14923f01ad402172857
_mkto_trk = id:645-COJ-341&token:_mch-sketchup.com-1430841266767-88700
optimizelyBuckets = %7B%7D
optimizelyEndUserId = oeu1418222701911r0.02056718268431723
optimizelySegments = %7B%222242991389%22%3A%22search%22%2C%222246811108%22%3A%22false%22%2C%222249451837%22%3A%22safari%22%7D


#4

Ha, repro’d it. It’s a Google thing: so I pasted that lat long into maps.google.com, and zoomed way in. Google now has camera height in meters in the UI for earth view. So I switched to map view, which still has the tile height, and I zoom in until the url said level 21 (21z), then switching maps.google.com to earth view, I noticed the map zoomed out a bit. Try it yourself - it’s interesting to watch.

Oops - that was a developer version of non-production SketchUp. When I try it 2015, I get the pix just fine. Hmm… this will take a further look.

Edit: OK, I did get it on 2015 by clicking on zoom in an extra time. Workaround - go to that same location and zoom out one click of the mouse, and it works. I think this one may be on us, not Google, but we’ll confirm.


#5

the workaround worked,

it’s a little odd, I had a look with Web Inspector but couldn’t find anything going awry…

cheers

john