Google G Suite Login Issue

I’m trying to use sketchup for schools and after I login to my school G Suite account (domain it goes back to the “Are you in the right place?” screen and lets me sign in with my school account again (which it already knows).

There’s a link on the “are you in the right place” screen which takes you to a page to check that sketchup is installed for schools on my domain. That page says “This application was installed by your administrator.”

The school district domains are and (Denver Public Schools)

Hi there!

It sounds like you’re stuck in a login loop. Here are a few steps you can try to resolve this issue:

  1. Clear Browser Cache and Cookies: Sometimes, old cache and cookies can cause login issues. Clear your browser’s cache and cookies, then try logging in again.
  2. Check Browser Compatibility: Make sure you’re using a supported browser (Chrome, Firefox, or Edge). Sometimes, using an incompatible browser can cause issues.
  3. Ensure Proper Permissions: Even though the application is installed, your school administrator needs to ensure that the correct permissions are set. They should:
  • Go to the Google Admin console.
  • Navigate to Apps > Additional Google Services.
  • Find SketchUp for Schools and make sure it’s turned on for your domain.
  1. Try Incognito Mode: Open an incognito window in your browser and try logging in again. This can help bypass any issues with extensions or previous sessions.
  2. Contact Your Administrator: If you’re still having trouble, it might be best to contact your school’s IT administrator. They can check if there are any restrictions or settings that need to be adjusted.

If none of these steps work, you might want to reach out to SketchUp for Schools support for more specific assistance.

Hope this helps and you get SketchUp working soon!

Hi @CMiner, thanks for the post and sorry to hear that you are having difficulty accessing SketchUp for Schools. I just ran a quick test to make sure our servers are up and they are all reporting that they are online and I can confirm that your domain is in our database so it is definitely not an issue on our end as far as I can tell.

If you are still seeing an issue as of this post my first guesses would be that a setting got changed by mistake on your end or a bad cookie or cached file is causing an issue. If you can check in with your IT team and see if anything was updated recently that would help us rule out a setting getting changed and clearing cookies and cached files would eliminate that possibility.

Can you try doing that and let me know if you are still seeing any problems?

I started with clearing the cache. Always a good move in situations like this. I’d tried accessing the app on Chrome as well as Firefox. I tried incognito/private mode on chrome/firefox. Nothing has worked yet.

Could there be a problem that my google login domain is but the school is

I’ve tried logging in after clearing the cache in both chrome and firefox. Also tried incognito/private mode windows. So I don’t think the problem can be a bad cookie or cached file on my computer.

I’ll contact the district IT people and see what they say. I did clear cookies and cached files. That didn’t help. They are closed today, so I’ll try them another day.

Sure. It would be nice to have this working.