Global vs Component Axis Agreement


I believe my component axis agrees with my global axis, but when I try to push-pull to a line created on the green global axis the distance varies depending where I am on the line.

If I do the same on a line created within the component, the distances are the same all along the line.

I’ve tried resetting the global and component axes, but no change. What can it be?

Here is my Sketchup File.

I’m not following what you are asking for. I do notice that you’ve moved the global axes in the model.

Nothing is square to begin with here. Both the line and the starting location of the two bars are out of square by very small amounts.


Gotcha. Not sure where to go from here or why a) a line I just drew on the green axis is not square, or b) why the faces of the component light up as red, green, blue.

Can you suggest steps to adjust my existing work?

I or another will take a look after dinner☺️. There will be a way to sort it out and get going again. In general it’s been established that color by axis has a tolerance which in some circumstances allow for false positives and small errors.


Traced the problem first to having reset the axis in an attempt to make them square with the entity labeled “existing home” but the green was actually a fraction off, I reset again using inference to match the front edge, of course this all assumes that entity is square as well which it does not appear to be, the corners are not 90˚ none of the edges align. How did you initially make this geometry, is this traced over a an imported bit of geometry? I think you could benefit from using the inference engine cues when modeling to insure that geometry is square and from entering dimensions directly by typing them as you model to avoid all these tiny random decimal lengths.

I had to tweak both ends of the rails to get them the same length and square with the line, but that part at least is now square, not much else is.


I haven’t downloaded this model, as I have a very limited connection I’m always aware of the file size.
16 mg looks too much for what I’m seeing in your gif, perhaps it needs a purge.

Its got a bunch of geometry including geolocation hidden, some of it with separate tags, some just raw hidden geometry and some survey data as textures. It’s been purged and I could not make it any smaller without dumping geometry. I suspect it’s been made from a dodgy dwg or just traced out sloppily over an image.

1 Like

Ok, I’ll leave you with it.
I wasn’t suggesting the size was relevant to the issue, just making the note for the OP that it’s better to purge your models before uploading them to the forum as we tend to download a hell of a lot and it all adds up.


Yes, tracing Google Earth satellite imagery.

I usually look to click to the axes, but I just realized what I did differently here. I left the axes unchanged from the location axis until I was convinced I had a good trace. And to your point, I then would have needed to use the inference engine to keep things square, but forgot the importance of that when not having yet set the global axis to my main object.

Lesson learned.

Can I simply 1) go around the corners of the “existing house” entity drawing new lines that follow the red and green axes and erasing the other two sides of the triangles that creates, then set the “Beams” entity to the same axis?

The Beams entity was not ok by itself? Seems equal to me.

I believe I have my model all square again and my original concerning behavior is now working as expected.

Thanks so much, @endlessfix !


1 Like

Didn’t have a look at the model, but another reason for small differences can be the option “length snapping” in the preferences, make sure to turn it off and/or use a template without this active option.

My issue was failing to getting lines parallel, which sounds different than snapping to the nearest .01 mm etc. That said, I’ve seen other cases made to turn it off.