GKware won't run on sketchup

I paid for and downloaded GKware Cabinet Maker V6. The extension apprears but i get the following message when i try to start in sketchup.

“No such file or directory @ rb-sysopen-” …blahblahblah

3_4 X 3_16 slots

Any suggestions?

This wouldn’t be a SketchUp bug. Looks like either an issue with the extension or improper installation.

Try contacting @gkernan. He should be able to help you out.

Does that file and/or subfolder exist ?
It might be that there are insufficient permissions to make/write/read them ?
Try a Repair on your SketchUp installation…
Close SketchUp and find its installer exe file - usually in Downloads…
Select that exe file’s icon, right-click > context-menu > ‘Run as administrator’…
When prompted choose Repair…
See if that helps…

Alternatively try renaming the subfolder so it’s remade as a new one, or deleting the tmp file in case it’s got bad permissions etc…

hmmm, tried running as admin… no change

This is what i find in the folder

OK thanks…Tried contacting @gkernan@telus.net and he told me to contact him over skype, to which he seems not available.

I’ve also tried many times to reach @gkernan to no avail. I’ll be reporting this extension as fraud to my Visa company on Monday. Highly suggest nobody wastes their time with this, stick to ACA or other extensions in Sketchup that actually work when you pay for it!

Sorry - I had covid and then ended up in the hospital for 2 weeks. I’m out now but fairly weak.
Please provide me with your userid and the date you purchased a license and I will update your account


CabMaker 7 is now available from my website


  1. Download the latest trial
  2. Load Sketchup
  3. Run Extension Manager
  4. Click Install Extension and navigate to your downloads folder
  5. Choose the package that you just downloaded.
  6. Restart Sketchup

I;m looking at modifying my licensing so that I can be away without clients running into problems. Version 7 is now out