Ghost Elements After Manipulation

Lately, I’ve noticed odd behavior in SU. The issue stems from simple operation during an SU session, whereby after highlighting and deleting elements in a file, and then subsequently highlighting new objects for manipulation, I either have:

  1. My cursor selection box appearing away from where my clickspot is on the screen, which causes me to have to cancel the current operation and try re-selecting again.

  2. A “ghost” version of the previously selected elements appearing then disappearing, during a new operation.

As I said, this is a recent issue, meaning that during the whole of my time using SU, I’d never experienced this before. Annoying as it is, nothing appears to be corrupted in the file, and i say this because after it started initially, with one of my files, I assumed something was nozzed up, and started a new file, but even that new file is having the same problem.

To troubleshoot, I performed the following:

  1. Experimented with styles, reverting to default, creating my own, but the issue remained.
  2. Created a new blank template file, thinking the file I was using was corrupted somehow
  3. Tried turning features off and on, such as hidden geometry, but that too made no difference.

I have about 5 files right now, that I have recently created and all of which have this problem, but this is not to say that all of the files have some sort of anomaly in them because I’ve done purges and error checks to them all and they are clean. I would expect this problem to occur with really large files, but the files I have, including the latest, are rather small in size and don’t contain any weird geometry either.

I realize this is a long-winded post, but I really didn’t know how I could properly convey the issue without explaining everything properly, as well as laying out the troubleshooting I’ve done.

Maybe someone has had this problem, maybe not, but if anyone could shed some light on the problem, I’d be very grateful.

So this implies that something has changed with your system. The kinds of things you describe are most likely graphics related and it isn’t uncommon for Windows users to see odd graphics behaviors after automatic Windows updates.

Here are a few steps to make sure everything is correct.

  1. Download the most recent version of SketchUp 2019 if you don’t already have it in your Downloads folder. With SketchUp and LayOut closed and logged in to Windows as you usually do, right click on the installer and choose Run as administrator from the Context menu. Then choose Repair when the option is presented. This will ensure that SketchUp has been installed correctly.

  2. Go to the Nvidia control panel and make sure that the Nvidia card is set to be used with SketchUp. It’s not uncommon for Windows updates to make the integrated GPU the default. If that happened, you want to fix it. It should look something like this:

  3. Go to the Nvidia site, download and install the latest drivers for the card. Don’t trust Windows to tell you that the drivers are current.

  1. Been using the latest version (including the latest update released), nothing has changed there.
  2. My nvidia is always used on my system, and in fact, I have a profile set up in the nvidia control panel for SU.
  3. I always maintain the latest drivers for my card, by way of notifications through the GeForce Experience App.

Did you install SketchUp as I described using Run as administrator from the Context menu?

Have you checked the OpenGL settings in Sketchup Preferences to ensure that it is using the Nvidia card?

Yes and yes

In Preferences, OpenGL, what is the state of the Use fast feedback checkbox?

See attached

What happens if you enable Fast Feedback?

Yes, what Dave says. That’s the usual cause of the symptoms you’re seeing.

Nope, no dice, whether fast feedback was on or off. I opened my most recent file, selected and deleted some elements, then when selecting new elements, the old ones briefly showed up then disappeared…very strange.

Newest isn’t always best, try rolling back your Nvidia driver.

1 Like

Actually, on a hunch, I disabled multi-sample anti-aliasing (dropped it down to 0x), then tried the same scenario, and I no longer got the ghosting. It would seem that the 8x setting I had was too high for SU to function properly. I’ll try 2x back up to 8x and see where the threshold is before SU wigs out again.

Btw @Box , I have been keeping up with nvidia drivers, and have had zero issues with any app. This case, seems to be constrained to SU functionality for high multi-sample AA.

Thanks for trying the antialiasing test. Generally 2x or 4x are plenty good enough quality. 8x is perhaps 64 times as demanding as 0x.

After doing a quick run-up through the msaa setting, I got stonewalled at 2x. Enabling that, caused the ghosting, so I guess it’s 0x for me. I find it odd, considering I have a pretty powerful graphics card. Anyways, thanks to all for the troubleshooting.

Until now, which is why you might consider rolling back, particularly if it was working happily at 8x previously.

@box, actually, I updated the driver yesterday, so the previous version gave me issues, just like the latest version giving me issues now.

Ok, I’m just relating that from my experience with Nvidia drivers, often the newest doesn’t work correctly and many times I have remained on an old driver while testing many new releases until one finally works. It took as long as a year in one case for me.

I tend to be a “don’t fix it if it ain’t broke” kind of person, and I would tend to agree with your line of thinking, but considering that this computer I own, is fairly new and has been a real champ through everything I do with it (from gaming to modeling), so I never saw the harm in updating when new updates emerged. Maybe, just maybe there is a bug with nvidia’s drivers, in this particular case of using MSAA, but honestly, I can live without the usage. I run vray in SU, so if I need a “perfect” view of something, I have that to work with. If I was inclined to do so, I’d file a bug with nvidia, IF it’s truly a bug with their driver, OR maybe Trimble needs to look into the MSAA setting in their software too…hard to tell right now.

All my models now show this ghosting issue which I don’t believe was there 2 weeks ago. I have tried changing the graphics card options suggested above and I see no difference.

Have you tried turning off Fast Feedback? (Window menu>Preferences>OpenGL). Close and reopen SketchUp after changing the setting. This is the most usual fix for Intel integrated graphics cards. You should too go to the Intel site and look for an updated driver for your graohics chip type.