Get rid of outlines when animating!

I have been struggling with this for a while and have nt found a solution

When I try to animate scenes, it automatically put back the outlines I repeatedly (hide) deleted.

How do I stop it form happening?

I’ve done the wireframes view, then hide, but it doesn’t work. I’ve gone in certain areaes and hide each edge, but as soon as I animate, it adds them back!

This is SU Make 2017 on a Mac running 10.14.3

I also used to be able to use Twilight to render photo-realistic animations, but apparently that stopped working too.

Is it sketchup wanting you to buy the pro version??

Thanks in advance.

You should probably post an example so we can see.

From what I think you are saying, remember you need to have outlines/edges off before saving each scene.

When you press play on the animation each scene displays how it was when it was created. So if you change the scene or edge style afterwards and then press play it will always revert to its earlier state upon creation.

Still catches me out all the time!

1 Like

Most likely the issue is due to your graphics card not being able to keep up with the animation. Things are set up so when that happens, textures and shadows will be turned off and only edges will be displayed until the graphics can catch up.

Well, of course they’d like to sell the Pro version but that’s not why this is happening. Of course if you are using SketchUp for something other than hobbyist use, you would need to have SketchUp Pro anyway.

Seeing as I have the best graphics card available in 2017 (AMD Radeon R9 M295X), I can’t see that being an issue. I can run C4d, premier pro etc, with very little to no lag, so i’m pointing to another issue.

Appreciate the response.

I have repeatedly started with no edges and when previewing sometimes it doesn’t show edges, but most of the time it just throws them back on. When I export the animation, it makes the edges even thicker than what the preview was before the export.

Again, much more helpful if you share some images/files.

When I make a scene with no edges, as soon as I hit the scene, it throws the edges back on. SOOO frustrating. It also throw profiles along with edges. I can’t tell you how many times it has been deselected.

According to at least one benchmark site, it doesn’t seem to perform well with OpenGL which SketchUp requires.

Are you updating the style after making the changes?

yes. The scene is not keeping the styles at all.

Upload the SKP file so we can see exactly what you’ve got. I’m sure there’s an easy fix.

There are no warnings at all. It is super fast when working, or exporting. I can’t understand how it would automatically put outlines or edges on everything when you create a scene. That is really what it is doing.

One more time. Share the SKP file. I’m sure there’s an easy fix for your scene problem.

If you’ve edit the style after creating the scene, you should get a warning telling you so when you do update the scene.

in the scenes dropdown, make sure the styles is checked as well as updating the scene.
will look a little different to this on your mac.


outlines.skp (116.8 KB)

I can’t upload the entire file, but this is doing the same thing. Just a part of the file. WHen I hit the “scene” it adds outlines and edges with profiles. I deselect, update scene, but then when I click on the scene, it automatically puts them back

Yep all of those are checked. I am creating the initial scene without the edges and profile being checked, but it is automatically adding those each time I hit the scene.


After editing the style to turn off the edges, do you get this warning when you create a new scene or update an existing one?

No, nothing like that. I am unchecking the “edges” and the “profiles”, before making a scene. As soon as I click on the scene, it adds those back.

If I am creating the scene without those being on, it should hold those settings. Right?