Geometry won't paste from Sketchup 8 into Sketchup 2020 Pro

Hello all,
I’m experiencing some issues while trying to copy any geometry from Sketchup 8* (while working on it) into the new release of Sketchup 2020 (V 20.1.229 64-bit), previously it worked as usual with the Sketchup 2020 V20.0.363.

On the other hand if I try to paste some geometry from Sketchup 2019 into the new version of 2020 it works just fine. (haven’t tried other versions)

I read there was some similar issues to copy between models on the Mac version but the solution of “paste in place” doesn’t work either (that’s what we usually use).

*Unfortunately we rely on Sketchup 8 to perform a procedure in an old extension no longer maintained, currently using a workaround of “saving as” a component of the geometry we need to work on using Skp 8 for the procedure and reloading back into Skp 2020 when done.

I didn’t upload any files as is not a specific model that makes this issue but any.

I’ll post back if I find something else.
Tried disabling all the extensions with no luck.
"C:\Program Files\SketchUp\SketchUp 2020\SketchUp.exe" /DisableRubyAPI

What procedure?

Have you tried running your old extension under v.2020? It might work. I sometimes use an extension developed for SketchUp version 4 without problems.

3 Likes

Thanks for the replies.

@MikeWayzovski we need to use an extension named “FerrariSketch” that calculates the shape of tensile covers. Similar to “Soap skin & Bubble”.

@Anssi I tried changing the zip extension to .rbz but doesn’t seem to install everything. Then tried manually copying the files into the respective folders but didn’t work either. Since there’s no “plugins” folder, not sure if we actually need to put them in a different folder instead of “tools”?

Thanks

You might be out of luck as far as getting that to work in SketchUp 2020:

1 Like

SketchUp 2020 does have a plugins folder. On Windows you can find it at %appdata%\SketchUp\SketchUp 2020\SketchUp\Plugins, not sure what that would be on Mac.

What kind of files does the extension contain? Does it have compiled code (.dll, .bundle. and other files you can’t open in a basic text editor) or just .rb files (and images etc)? If the extension has no compiled code it should likely work in all newer SU versions.

1 Like

Mac plugins go here:
~/Library/Application Support/SketchUp 2020/SketchUp/Plugins/

I found it on SketchUcation here. The original had .rbs scrambled files, no compiled code, but must have had something incompatible with versions newer than SketchUp 8.

I also found a version that someone had rewritten for SketchUp 2015 here:

http://www.sketchando.net/descargas/plugins/FerrariSketch1.1v2015.rar

2 Likes

I wonder if it’s a procedure problem or a model file size thing. I don’t have SketchUp 8 anymore but I do have 3.1 and copy and paste work just fine from 3.1 and 2020.

2 Likes

Thanks all for the help!
@McGordon, yes I actually read that post a while ago and gave up on trying to install the extension in newer versions than 8. Many thanks for finding the updated version of the extension works great now and the problem with the geometry that doesn’t paste won’t be an issue anymore.

@eneroth3 thanks for pointing the location of the folder, I had only looked into %programdata%… :blush:

@DaveR it’s any kind of geometry even with a clean model and just a square. If I copy it and try to paste in V19 works fine but not on V20.1.229. (used to work on V20.0.363).
The updated extension @McGordon found will solve our issues.

Thanks again for the help! going to mark as solved, I actually got a better solution.