Geo-location stopped working

When I try to geo-locate the model, I get a message saying “Sorry! You must be logged in. Please close this window and sign in to SketchUp by clicking on the Account icon. Look for it in the upper right corner of the modeling window.” Two problems: 1. It says I’m signed in already. 2. There is no Account icon in the upper right corner of the modeling window, or anywhere else that I can see. How can I geo-locate the model? By the way, Geo-location worked perfectly until I got the email announcing the Nearmap option.

Edited to add: I’m using SketchUp Pro 2020 Version 20.1.235 64-bit on a Windows desktop

What version of SketchUp are you using? Please complete your profile.

SketchUp Pro 2020 Version 20.1.235 64-bit on a Windows desktop. I don’t see any unfilled fields in my profile.

When you installed SketchUp did you right click on the downloaded installer and select run as administrator? If not or you don’t remember, you should go ahead and do that and repair the installation to make sure.

Your profile should include the SketchUp version, license, operating system, and graphics card. Yours looks like this:

Click on my name to see what mine looks like.

I got this message yesterday as well, perhaps due to the recent changes in Geolocation options. Signing out and signing back in once solved it. The option to sign out and back in should be in the upper right corner of the window. It should look like this:

If you see a small set of arrows at the upper right then your window is too small to see the sign in icon.

That’s not what I was referring to regarding Ellen’s profile but signing out and back in to SketchUp might help.

I saw a screenshot from someone else that didn’t have an avatar in the tools area. You can sign in or out from the Help menu as well.

Okay, my name says all that stuff now.

1 Like

hello ,
i have the same problem here but my version is pro 2018 on a PC and i dont find this SIGN in button … someone can help me to find a solution?

thx in advance

For the 2018 version, the sign out and in are a bit different and are located in the bottom left.
If you used Google, I think it won’t work, Google’s sign in from within SketchUp are not allowed anymore.
You have to have a Trimble ID (All things for SketchUp)

In any version of SketchUp there is a sign in option in the Help menu as well.

You could be logged in with different ID’s, even! The 3D warehouse, Extension Warehouse, be sure to sign out on all of them.

hello guys thanks for answering.

i have a trimble id and i can connect to it in “file-trimbleconnect” but after that i cant connect to google location…

i dont find the button in the left corner (u tell about PC?)

also i cant find the button in help menu (picture)capture help menu

if u mean license … i have a licence and im in

OK guys , MIKE you find the solution it’s because i was not connected to extention warehouse or connected with another account

THANK YOU ALL !!

1 Like