Geo-Location Sketchup 2022 Pro Woes

I’ve been trying to load a Geo-Location image into SketchUp 2022 Pro. I have done this in the past with no issues, but after upgrading to 2022, I am only able to see a colored shape the size of my selection.
Having read through other threads, I tried all of the suggested solutions to no avail. Turned on textures, colored by tag, tried different locations, etc.
Included are screenshots with examples.
Any other ideas?

Have you tried reducing the resolution?

in your screenshot, you are in “colour by tag” mode. the tag is orange, the rectangle too.

check the tag panel on the right, the 3 tags top right are coloured.
(or in your style panel, uncheck colour by tag)

click on it, does it revert to standard ? if not, can you show us what’s going on then (with colour by tag unticked)?

1 Like

Good catch!

Thanks for the responses.
Well, it turned out to be greed! By simply reducing the resolution desired by the import from Bing in the Geo-Location window.
What I am curious about and need to try, however, is to import from a more populated location to learn if I can get higher resolution elsewhere. I live in Denali, Alaska USA where there is a dearth of quality satellite imagery.
Apparently, if you choose too high of a resolution, the image portrayed in the shape is a pattern generated by geo-location. This can be toggled between color by tag, etc.
Thank you again for your responses.

Bing does have higher resolution imagery in some areas. I would imagine that coverage increases over time. To get very high res you would need to use NearMap.

I’ll give that a try. Thanks.