Geo-Location loading terrain, but not images

Hi everyone,

I am attempting to add Geo-Location to a new project and I’m having difficulty. In the past (circa SU2017) I haven’t had any issues with this feature, but I haven’t used it in quite some time, so I’m not sure if I’m missing a step:

  1. I open the Geo-Location menu.
  2. Select the region I want.
  3. Click Import.
  4. After a few moments the region boundaries appear, as well as the Location Snapshot and Location Terrain tags.
  5. There is no imagery in the snapshot, just a “no camera” icon.
  6. I turn on the Location Terrain tag and I see the terrain, but still no imagery.

I have played around with the max allowable tiles, very few tiles, and still no imagery.
I have tried it with a different location and everything works fine. Is it possible that even though the region I want is clearly visible in the dialog box, but somehow not available for download? Are there areas of “restricted airspace” so-to-speak? The area I want is near a local airport, but I can’t imagine it is classified.

I hesitate to share the exact location for privacy concerns, but here is a screenshot of the results:

For reference, this selection was only 160 tiles. I have also tried the max of 1250 tiles - same result.


That indicates you have the resolution set to high for the area and Bing Maps doesn’t support that resolution. Back it off a notch or two.

What’s the location?

Jeez Dave - you could have at least pretended that this was a tricky fix!!! But of course, you are absolutely correct! I backed the resolution off one notch and BAAM! I had played with the upper end of the scale, but didn’t think to drop it down - you are once again proving your undeniable value to this forum!
The location is a rural property in Ontario, just south of Collingwood.
Thank you very much for your lightning fast response!

LOL! Sorry. Next time you ask a question I’ll try to make it a harder fix.

Stand on one foot, stick out your tongue on the left side (no, your other left), put your elbow in your ear, and say “sodiumcarboxymethylcellulose” three times quickly. :crazy_face:

I’m glad that got it sorted. Hopefully Bing will be able to supply high res imagery in more areas soon. I don’t know how they are acquiring that imagery but with the SR-71s all retired they have to have some other source.

1 Like

I like it! Makes me feel like less of a schmuck! Sometimes the answers are so obvious that I wonder how the heck I missed them.

Thanks again Dave!


Is that anesthetist speak?

What? The sodiumcarboxymethylcellulose? No. That’s the lump of stuff left in the bottom of your bowl after the ice cream has melted. Or at least it used to be that. Now it’s probably some kind of petroleum by-product.

1 Like

Can the location importer not alert client what resolution is available? trial and error to find a resolution that loads is tedious.
I like some aspects of new interface, but this is very annoying