Geo locate opens when I press space bar


#1

Every time I press the Space Bar, the Geo Locate window opens. How do I make this stop?


How can you disable geographic location?
Keyboard Shortcut Errors in 15pro on mac
#2

i assume you’re on mac and if so, i assume you’ve inadvertently triggered a shortcut which causes the tab key to move between all controls (and in sketchup, this causes focus to be on the geolocation icon at bottom left)

anyway, do this:
go System Preferences-> Keyboard-> Shortcuts

at the bottom of the dialog, change your setting for Full Keyboard Access back to the default setting of “Text boxes and lists only”


#3

Look for the little blue halo on the Geo icon in the lower right. If this really bugs you, you can hit tab 4 times when you open SketchUp, and then the little blue Mac halo will be over the select tool. Space bar selects whatever the little blue halo is on. It’s a Universal Access thing.


#4

Thank you both! Fixed.


#5

A very late reply but if you wanted to keep the Tabs for all controls, one workaround which I was hoping there was a better one, is to Minimize the drawing you’re working on then Maximizing it back up - that’s my workaround so far as I do want to keep Tabs for all controls.


#6

there is a System Shortcut to toggle Tab 'ing, found on the same dialog…

Ctrl + F7

john


#7

These solutions are not working for me on my macbook pro with SketchUp 2016. I do not see an option for disabling keyboard shortcuts. Where is this?


#8

You’re a life-saver. Thanks, this was driving me nuts.