Generating square grid terrain mesh

Hi, relatively new to Sketchup. I have a high-resolution point cloud generated from a DEM raster. I’m trying to generate a terrain mesh in Sketchup from the point cloud. I’ve already tried Fredo6’s TopoShaper point-cloud extension but the algorithm is overly complicated for this application and as a result can’t handle this many points.
The points are in a perfectly spaced grid, so the easiest way to generate a simple mesh would be for every point to connect to the next point in +X, -X, +Y and -Y with a line.
Is there any way to do this easily? I don’t require advanced triangulation. Just a collection of simple squares.

Try with TIG Triangulate Points plugin

pag-04

You could select parts, not the entire cloud points, and see if it’s working and create the surface from smaller parts.

Or you can use CloudCompare and generate the surface from cloud points, export as OBJ, and import in SketchUp (using Universal Importer, Transmutr, Skimp, etc. for geometry simplification and import).

1 Like

Wow, thanks for the great suggestions. With over 600,000 faces, the Triangulate Points plugin still had a processing problem in Sketchup, but CloudCompare worked great. I used it to generate a Delaunay 2.5D triangulated mesh, saved it as an .OBJ, imported into MeshLab for selective decimation and then used Skimp to import it into Sketchup.

Now that I have the object in Sketchup, I’m noticing a rendering problem. When I’m “at a distance”, the terrain renders perfectly. But as I zoom in, I start to get “drop-out”.



The severity and location of drop-out changes dynamically as the viewing angle changes.
Any idea what’s causing this rendering problem? Is there a setting in Sketchup that can fix this?
I’ve already enable “Hide Rest of Model” in the View menu.
Interestingly I get the same “drop-out” or “tearing” effect when zooming in closely in MeshLab, but not in CloudCompare.

You’re welcome!
In the second photo some faces may be missing (the axes can be seen behind those areas). They may have been lost during decimation or import (?!).
In the third photo, the rendering errors may be due to the very large size of the surface or the existence at a great distance from the origin of the geometry or maybe there are even missing faces.

You can use just Skimp