Generate report, wrong quantities

sketchup
generate_report

#1

Hi Everyone,

I want to make my current SKP models a little more useful, to save me working out part quantities by hand I would like to do this through the SKP reports.

However when I add the quantity attribute It displays “1” and shows the other copies below as “1” instead of bulking all components together.

As well as this I would also like to add a weight attribute but I’m not sure how I would get this to display a total weight at the bottom of the report?

Attached is an example SKP file.
TL34-20.skp (2.0 MB)


#3

For some reason, the model imported showed ‘Copies’ attribute in Dynamic Components, this is not the right attribute for counting copies in the model. Counting is done in the Generate Report.
depending on which version you use (Your profile does not give us a clue) Generate Report gives you different possibilities.
Though you can use your own (weight) attributes in Dynamic Components, you can also use the advanced attributes in the entity-info for quick reports.

I exploded your component, purged the model and made it component , again:


#4

I have seen a couple people use that component quantities report… have you made this or is it a default report?


#5

I have edited the standard Quantities Report for this, but I use version 2018, it is different on other versions…


#6

I use 2018 as well and I think I remember deleting the default report… would this explain why it still doesn’t work?


#7

You can not delete the default template, I guess:

you must have renamed it?

Start a new file, import the model (as model, you might want to ‘unwrap’ the outer shell first) a make a new report ([File]->Generate Report and start from there…

You can save the report to model or export it as GRT (Generate Report Template) file

here are the files:

Truss.skp (2.2 MB)

had to zip the .grt file…

Truss Report.zip (532 Bytes)


Generate report error..Help required
#8

This video presents the fundamentals of generating a meaningful report.


#9

This worked perfect and it also shown what the issue was… I hadn’t used the “group by” section which was why nothing was bulked or grouped.

Many thanks for your help.