Garden model very laggy

Hi everyone

I am designing an allotment plot. It will be packed to the brim with trees, shrubs etc. The problem is, it’s not even half full at the moment and very slow to load any new components. It doesn’t seem to have a problem orbiting once items are in place.

I recently purchased a new laptop, a Lenovo X1 Tablet 3rd Gen. I know it’s not the most powerful laptop (Windows 10 Pro, Graphics: Integrated Intel® HD 620, CPU: Intel Core i5* -8250U Processor 1.60GHz, SSD: 256GB (most of which is still unused)), but it’s better than my last one and that ran sketchup fine.

The model in question is here: https://3dwarehouse.sketchup.com/model/239b2a08-31f8-48c5-b30b-0cf9db236cfd/Allotment-Design

I’ve done everything I can on the computer side to ensure I’m getting maximum performance i.e. cleared cache, keep internet browsers to minumum, stopped background processes, putting performance settings to max etc.

On the sketchup side of things, I followed tips from the Sketchup Essentials Youtube channel. i.e. changing style to default, unchecked profiles, copy components rather than build them individually, purged etc.

My file dropped from 62MB to 14MB, however it is still very laggy. I tried opening a detailed building larger than 14MB, and it seemed fine.

The whole purpose of me designing this on sketchup is infact to see where shadows are cast. But even after I turn off shadows and sun shading, it really struggles to add any new components.

So my question is this, is the problem:
A) My laptop is not powerful enough
B) Settings in my model are still not optimised
C) My components are too complex (Most are less than 0.5MB, a couple are 1-2MB, but no more than that)

MODEL INFO:
Edges: 1,437,186
Faces: 680, 910
Component instances: 7836

I don’t want to get a new laptop ideally. I currently have about 20 plants in the model, but could end up with up to 200. If I have to use simpler components, that’s fine, but what sort of specs should I be looking for with trees for example?

Thanks in advance!

According to the sketchup requirements:
Recommended hardware

  • 2+ GHz processor
  • 8+ GB RAM
  • 700MB of available hard-disk space
  • 3D class video card with 1 GB of memory or higher and support for hardware acceleration. Please ensure that the video card driver supports OpenGL 3.0 or higher and is up to date.

SketchUp’s performance relies heavily on the graphics card driver and its ability to support OpenGL 3.0 or higher. To test your graphics card’s compatibility, please download and run the SketchUp Checkup application. Historically, people have seen problems with Intel-based cards with SketchUp. We don’t recommend using these graphics cards with SketchUp at this time.

Your system looks not sufficient for sketchup.

How does the REV model attached run?

I have an example model from someone that is four times as demanding as your one was before you optimized it. It also is a lot of vegetation. Here are suggestions I made for that customer:

When getting a particular plant from 3D Warehouse, uses the advanced options on the left. One of those is a polygons slider, try positioning that about half way, and keep changing it until you see a model that is good enough to do the job. It would be worth swapping out your existing components. In the components panel you can right-click, Select Instances, of the demanding version, then right-click, Replace Selected on the less demanding one.

Make a layer just for the vegetation, or some layers for different things (trees, bushes, for example). You can then hide those layers while working on the model, and only turn them on when you’re exporting images.

In the model I am testing, which its not otherwise a complicated model, it has 42 million edges. For a comparison, I downloaded a New York City model, and it has under 15,000 edges. So I tried a way more detailed New York City model. It was 157,489 edges. 42 million is a lot.

Typically, if the edge count goes beyond the 1M, you need to find a different approach or other components, as suggested.

1 Like

Thanks to everyone who responded. Firstly to answer Tengel07, I ran the Sketchup Checkup and it says my computer meets all the minimum requirements.

In answer to Aroberts, the REV model works fine, but as I said, orbiting the model seems to be pretty smooth (at least at the moment). It’s when I go to add a component it becomes really laggy, making it really difficult to position in in the model. And takes quite some time to save the model.

WHat is a REV model by the way?

To Colin and MIke, I will play around with rebuilding the model with lower polygon components. So is this 42million edged model very laggy?

Well I can’t offer any help other than even with shadows on the model is pretty smooth on my end.
Specs:
SketchUp Pro 2019
Dell Precision 3630
Intel i7-8700
32 GB Ram
512 M.2 PCIe SSD
Nvidia RTX 2080

Orbiting is somewhat jerky for me
SketchUp Pro 2019
MSI Codex
Intel i7-9700 KF
16 GB Ram
512 M.2 PCIe SSD
Nvidia RTX 2070

Use plant models that are simpler. There is no way you can place 200 of these and keep it smooth, whatever the computer hardware specs.

Just trying to understand something here. I gather it’s all about the polygons, of which I probably have too many.
SO I searched for a high polygon model: https://3dwarehouse.sketchup.com/model/4e14bec7-b8a7-40a3-b5ae-9f8485cd3c7a/Warehouse-Peb

File size: 37MB
Polygons: 1,468,421
Edges: 4,822,672
Faces: 1,468,421

That compares with my model:
File size: 14MB
Polygons: 680,910
Edges: 1,437,186
Faces: 680, 910

I added some of my more complex trees to the warehouse, and didn’t seem to have a problem.

Given that the warehouse runs pretty fast when adding components, and that my computer passed the Sketchup Checkup, surely rules out my computer being too slow.

So if the issue is number of polygons, edges and faces, why is my model so much more laggy than a more complex one?

Just trying to understand what is going on here so I can rebuild correctly.

Thanks