Average face count


#1

I don’t know SketchUp very well, but my dad asked me to recommend him hardware to improve the performance while he’s working with it. However, with my GTX 980 / i5 6500 / 16GB RAM it’s still a little bit laggy when I open his projects and zoom out, or when focussing on certain places.

He’s new to SketchUp, and I have a feeling he’s using too many polygon-high models. I looked at Window > Model Info > Statistics. (I checked ‘Show nested components’, that’s to include everything I think?) It showed the numbers below. Could anyone tell me if this is far too many? This is for a medium sized garden, and he says once he’s using plants/trees it gets slow.

Faces: 434,060
Edges: 1,390,727

SketchUp Make 2016 / Win 10


#2

Hello! Personally my graphic card is a slow integrated Intel HD Graphics 3000 and I have 4GB of RAM. 2 years ago I did a grand project and I ended up with about 715.000 faces. If I view it with all layers and edges turned on it lags quite a bit. I’d suggest making sure your “Use Hardware Acceleration” is turned on. Also, if your shadows are enabled, turn them off while modeling. Cheers!


#3

Hey VahePogossian, thanks for the quick reply!

My settings are just the default ones. Hardware acceleration is turned on. If he zooms out and orbits it switches to wireframe right away for optimization, for me it doesn’t, but it’s a bit laggy. Your experience indeed makes this weirder, as this means I shouldn’t have any problem at all. Perhaps it’s the way his polygons are clustered? If I copy one plant in the scene which is relatively small it goes up by 8,710 faces and 18,539 edges.

Settings:

Section planes on
Section cuts on
Axes on
Guides on

Shadows off
Fog off
AA off


#4

Hey, I’m sorry, I forgot to mention that my model also temporarily switches to Wireframe/Bounding Box mode while zooming, rotating and panning. Do you keep your Statistics clean? If no, press the “Purge Unused” button to clean up your model from unnecessary stuff. Let’s see what other members of the SketchUp Community can help you with.


#5

My models are usually much smaller. Whatever the hardware, SketchUp zooming and orbiting will suffer when the face/edge count starts to run in the millions. The worst culprits are just those 3D plant and other entourage models that can be downloaded from the 3D Warehouse - they should generally not be used en masse. For most plants I would recommend using flat 2D face-me components - they can look very realistic if not viewed from too near. Most 3D plants manage to look unnatural even while using much more of your computer’s scarce resources.

Anssi


#6

A few other suggestions:

1 Use the CleanUp extension…CLICK HERE TO DOWNLOAD

2 Model in monochrome or hidden line modes only and turn on shading only when needed for specific scenes.

3 Make use of components for every item that occurs more than once in the model. Never model the same item twice.

4 Use groups sensibly. Place groups on specific layers and turn those layers off in every scene where their visibility is not needed.

(Although my suggestions 2-4 will not aid in reducing poly face count, these will help maximize speed and reduce the time in transitioning from one operation to the next.)