Gaps between texture when using "create unique texture"

Hi Everyone,

I’m new to sketchup and enjoying it so far. I am having an issue that I have been unable to solve as of yet and wanted to know if any of you more experienced users knew how to fix this problem.

When using the create unique texture function, I see small gaps between the newly created textures, which also appears in the game engine once the model has been compiled.

What I wanted to know, is if there is a way to stop these small gaps appearing when slicing textures in sketchup?

Here is an image to show what is happening. I am drawing a grid over a rectangle that contains the texture bitmap, then hiding the lines by soft deleting them, they still appear when hidden geometry is turned on.

Kind Regards,

The eraser tool doesn’t delete lines when using the soften modifier key. It just turns lines into hidden geometry.

I’m not sure what you mean by gap. Are you talking about a break in continuity of the texture when viewed from certain angles? For example, something like this:
Texture Hidden%20line

If you don’t use the make unique texture function to slice up the texture, then it shouldn’t have the gap.

Hi Forestr,

Thanks for your reply!

The hidden geometry was intended, what I am trying to achieve is to slice the background image into smaller sections, it is currently around 20,000 x 10,000px and will not work in the game in its current format. I was using the make unique texture function to cut the main image into smaller sections of around 2048 x 2048px to make it compatible with the game.

It’s not easy to see in the image, but there is a seam between the hidden geometry tiles, which shows a very slight gap between them and in turn shows gaps between the textures in the game like the image below.

1 Like

Also if it helps, this is the guide I was following to help clarify a bit further.

Would manually positioning the textures help? It’s in the right click menu. You can use the arrow keys for fine tuning. It might take a while though.

I gave it a shot and tried to overlap them slightly but it still shows up. If I zoom right in it looks like a shadow along the edge where the 2 textures meet. I had a look under the views settings and shadows is turned off.

I can hardly see the problem lines (not gaps), if at all in your second image. These lines, perpendicular to the runway look as if the are “part of” the runway. They don’t seem to continue.

But if… What if you don’t use ‘soft delete’ but just hide the lines.
And if that doesn’t help, then in this exceptional case assign a specific (other) layer to these hidden lines that you then turn off to make the lines invisible in all cases (hidden geometry on or off).
Then continue the process of tiling the image or whatever is needed.

The seams are noticeable when you pan around. It’s a bit less noticeable in the still image, but still noticeable enough to make it look tacky. I did try just hiding the lines, rather than doing the soft delete but the seams between the textures still appear.

And working with an invisible layer?

I tried placing the individual textures and hiding the lines rather than the soft delete, but the seams still remain. Im not to sure how to do it with another layer, are you able to give an example of what to do to achieve that?

Nothing special, just create a new layer and assign it to all the bounding edges that you have hidden. Then turn that layer off. And see if that helps in getting rid of these “gaps”. If you don’t try, you won’ t know.