Fusion 360 export project to SketchUp

Sometimes I need to import STEP files to SketchUp. Fusion 360 has a native tool to save a project as .skp file. But as SU has a problem with tiny faces the model needs to be scaled before saving as .skp. So when I try to scale the whole model in Fusion 360 by scale factor f.e. x100 all objects lose their position relative to each other. I was trying to figure out by myself what’s wrong and what to do to scale it properly but no success. BTW SimLab STP importer does import very long and even if I choose high-quality import in options still there are a lot of objects with a small number of segments what need to be fixed manually and take a lot of time. Are there anybody who uses Fusion 360 and got experience with exporting from it to.skp format?

I haven’t used Fusion 360 but generally applications that can save SketchUp files use far too many segments when converting curved surfaces to meshes for SketchUp. I don’t know if Fusion has a setting to control the coarseness of the resulting file, but if it has, I would try the absolutely coarsest setting.

I have used Rhinoceros to translate. Even there, the available settings produce far too many tiny faces. Therefore I have first converted the solid/NURBS geometry to mesh in Rhino, and then used the quite capable polyreducer command to further reduce the polycount before exporting as SKP:

Fusion 360 does the job nice when exports it to .skp file. But as I said there is only a Sketchup problem with tiny faces. I guess if it could be possible somehow to scale up the model in Fusion 360 before saving it to SU the result could be great. But I’m not strong in Fusion 360, I’d like use it only as a STP converter to SU.

change the import units to meters in SU and you bypass the small faces issue…

john

Fusion 360 generates an .skp file by itself and there it can’t be changed import units manually, this is simply skp you get

I have not experienced the small faces problem when converting .STP files to .SKP. Faces are very small but they do not fail to create. I have used both Fusion 360 and the Simlab STEP Importer extension. Both have worked, and both create enormous .skp files that are almost impossible to work with. This depends on the original file of course but in my personal experience the .skp file generated by the conversion process has always been so tessellated that the resulting file is very slow to use in sketchup. Simlab importer has an option for unit conversion in options but I’ve never used it. As I remember Fusion360 has a slider for quality on import which when set at worst quality makes much more faceted arcs and circles in the .skp format. But much of the file bloat is from tessellated or triangulated coplanar surfaces, using CleenUp3 helps. It chews on the file for a while (20-30min) but does reduce in the end. The following screenshot shows hidden coplanar edges in a STEP import (I can’t show the whole screen as it’s proprietary, but you get the idea), after running cleenup3 this file went from 144mb to 108mb and reduced hundreds of thousands of edges. Still slow to work with, but better.