From autocad to sketchup, the drawing is messed up

Hi there! I’m new to this community so in case I can’t explain myself well, sorry for that.
I’m trying to import my drawing from autocad to sketchup and some of the drawing parts are not in the place that they need to be. I’ve tried the flatten command but I guess there’s something wrong with the basepoints.

Thank you all in advance

yen.dwg (753.6 KB)

I tried opening your .dwg file in two different CAD applications (not SketchUp) and they wouldn’t open it. I would look at the the source and see what’s going on.

SketchUp warns of objects extremely far from the origin, but zoom extents does not reflect this. I"d check the CAD file first and see if it contains something very far away.

There is something weird going on. I see some groups of edges dancing around as I orbit. Looks like it should be the toilet but, if so, Picasso must have designed it.

I also don’t get the offset fixtures like yours, but also I can’t see an area quite like yours. The group at the upper left of your picture (looks like computer banks?) can’t be seen.

So I opened in PowerCADD. And then saved to a new DWG. It looks normal in SU, and the toilets are not cubist. So check the CAD file and resave.

On further inspection the drawings I see are different. Similar floor plans but the view you show doesn’t look like anything in the file I opened so I don’t know what to say.

Has this been exported from another application, like Revit? It looks perfectly normal in Autodesk TrueView. One possibility would be that the origin points of blocks are somewhere very far away, possibly at the origin point of the map coordinate system. I opened the DWG in Rhino and exploded everything to lines (I don’t have AutoCad), re-exported to DWG, imported to SketchUp and to me the result seems OK.yen2.dwg (480.0 KB)
yen2.skp (1.8 MB)

Save as .DXF and try my extension s4u ImportDXF.
It can help you.

Thank you so much for your explanation! When I inspected the blocks, one of the blocks that I used many many times in the drawing had it’s base point so far away and when I made it right, the problem is solved.

Also many thanks to everyone who replied :slight_smile: