Fredo's Curviloft not working

On Friday I produced the curve on the left, with Fredo’s Curviloft plugin (“Offset contours along the rai” method" turned off the PC and went home.


Back at it on Monday, and for some reason the Curviloft plugin is refusing to recreate what it did just 48 hours earlier. I’m getting the weirdest shape, no matter what I do.
Tried everything I could think off: rotating the circles, experimenting on different PCs at work, old versions of SketchUp, uninstalling and reinstalling the plugin etc - no avail!

Can someone please help?
We can’t move forward without recreating the curve on an updated path and the “Stretch rail between contours” is squashing the middle part, so that’s not the correct method. Here’s the file and another screenshot of the settings bar:

Test.skp (89.0 KB)

1 Like

I can confirm it works for me too. So it looks as though something has gone wrong with your Curviloft Plugin. though I’ve no idea why.

Try either re-downloading and reinstalling it or Updating it, and update LibFredo as well.

It’s now a paid for plugin - if your SketchUcation plugin isn’t also up to date the licensing won’t work.

1 Like

Hey there, thank you for the gif!
I don’t understand what’s happening…

Could you please tell what version of Curviloft you’re using and where you downloaded it from?
This is mine, I got it from here: SketchUp Plugins | PluginStore | SketchUcation

I am also noticing your icons look different than mine. Wondering if I’m using a different/obsolete version. But even that is a mystery because literally on Friday it was working as intended and I generated the left curve…

Like you, I got it from SketchUcation.

Here are my version numbers:

PS. I used (in English) the Loft along path option.


I created new icons for the plugin.

Further tests… I really have no idea what’s going on and my whole workday was ruined just because I couldn’t find the culprit.

Even tried an older Curviloft and Fredo Library versions. Still the same issue. Is there a way to directly contact Fredo? I think I’ve never met him on this Forum.

Can you upload your latest path and end faces as a .skp file? I can try it here for you.

Try orienting the faces of the circles so their back faces are toward each other. Also try drawing the segments of the path between them in the same direction. e.g. all left to right.

How do you try to create that model?

I’ve always used Curviloft the same way, and it’s always worked. Usually I put the 2 shapes into individual groups and leave the spline ungrouped. But literally nothing works today. I even tried welding the spline.
Interestingly, just asked another colleague to recreate the same. She is facing the exact same problem, albeit sitting in another office 500km away.

Don’t group the shapes. Leave the shapes and the path as loose geometry.

It’s in the video Dave. Both grouped vs ungrouped, selecting only edges vs with faces also…
Also tried reversing faces like you suggested, so the back faces face inwards - no success there.
Even restarted the laptop. I’m thinking about reinstalling SketchUp again if I don’t manage to find the reason behind this. Mondays are a pain in the back!


Found the problem (after 3-4 hours of further tests and experiments)!
I think this has to do with SketchUp itself, not the plugin (or versions thereof).

I went into my archives and found a dusty old installer of SketchUp Make 2017.

@Fredo6 I’ve already reached out to you in a message, but please have a look into this new screen cap too. 2023.0.367 vs 2017.2.2555. I am thinking I might have to remove all my plugins and reinstall 2023 to see if it will fix the problem. One thing I didn’t check with @mihai.s and @john_mcclenahan - what was your SketchUp version where you tried the SKP file I uploaded? Thank you again.

I am using v2023.1.341.

1 Like

Further confirmation if anyone comes across this thread in the future.
Curviloft’s “Offset contours along the rail” method is malfunctioning in SketchUp Pro v23.0.367 and v23.1.329. No problems detected in SketchUp Pro 2022 v22.0.354 and v2023.1.341.

I downgraded to 2022 because upgrading up from the installed v23.0.367 would mean having to deal with the new icons, which I could not bring myself to adapt to (both as a consumer and a Designer with over a decade of experience).