Curviloft extension doesn't do anything for me when i use it

i have sketcup pro 2020.
i downloaded the extension curviloft and fredo6.
Then when i try to use it it happens nothing.
Please the image.

What are you expecting it to do? Which tool are you using? If you add an edge or two between the shapes so you give it something to work with, it should work. You have to set up the geometry correctly for it to work.

What version are you actually using? Your profile says SketchUp Free (Web) which doesn’t have any capability to use extensions. Please correct your profile.

I’ m not able to change the profile for now.
But the version is 20.1.229 64 bit.
I did the same thing you do in the video.
but i noticed i have to right click to exit the tool

You can just hit the space bar to exit the tool. It doesn’t exit immediately because you might want to continue with another Curviloft action.

Sorry i never used a screen recorder but im not able to upload the video file where i do the same thing as you.

Save and upload your .skp file.

test.skp (177.0 KB)

I would make the line between the circles run between nearest points.

Select the geometry, get the Curviloft tool, click with the green checkmark. Since you haven’t anything else to run the extension on, left click in empty space when the green arrow shows. The Select tool is automatically activated then. I opened the resulting group and corrected the face orientation.

Personally I wouldn’t bother with curviloft for this shape, but having said that, use the first button.

1 Like

Nothing better on my side but i see this:
Error: #<NoMethodError: undefined method onSetCursor' for nil:NilClass> c:/users/me/appdata/roaming/sketchup/sketchup 2020/sketchup/plugins/fredo6_curviloft/curvilofttool.rbe:375:in onSetCursor’

And when exactly do you see that?

So you’ve been seeing this error message all along?

Go to Sketchucation and get the most current versions of both Curviloft and LibFredo6.

1 Like

you’ve been seeing this error message all along = No i just found ruby console in the windows menu.

Also i saw Libfredo6 setting and tried to update.

Go to Sketchucation and get the most current versions of both Curviloft and LibFredo6 =That what i did

It works now !
Finallly, i uninstalled all plugins for curviloft then reloaded, closed skechup and restart.
It 's fine now.
Thank you for your support @DaveR