Font is hard to read


#1

I find the typeface on this forum a bit hard to read unless zooming in. I have a pretty good size monitor too. Am I the only one who thinks this?


#2

@jsexton

Which browser are you using? I have used the forum on my Macbook Pro, my PC, and my cell phone with no issues. Perhaps it’s a setting? I would be happy to help troubleshoot it. If you could provide some screen shots, even better.

~Drew


#3

I’ve viewed it in Chrome and Internet Explorer.

Here’s a screen capture…


#4

@jsexton

Try holding down your control on PC (Ctrl) and using your mouse wheel to zoom. In Chrome, it has a pop up balloon in the top right that shows what percentage of zoom you are at. The screen shot looks like you are zoomed out in your browser. Your IE should have the same function, without the balloon.

Let me know if this helps.
~Drew


#5

It’s fine on my chrome:

Check your chrome settings:


#6

quantj could be right. The font looks like font-replacement and your browser(s) catch up the wrong font (maybe a narrow bold font like ‘Impact’). The forum uses ‘Helvetica’ or ‘Arial’ which are likely to be available, and if not, the browser should fallback to any available ‘sans-serif’ font. Check in the browser preferences whether the selected standard fonts are readable.
If it’s not due to the browser preferences, try clearing the browser cache and restart the session or the computer.


#7

I appeciate your help, guys.

quantj, I went into the settings as you suggested and my font settings seem okay.

Drew, it’s the actual font that looks different whether zoomed in or not.

It appears this way whether I’m in Chrome or Internet Explorer. I’ll try Firefox and/or Opera as well.


#8

I just noticed that he also mentioned he tested it in IE, so I wouldn’t know how both browser’s fonts got accidentally changed at the same time.

Edit:
Does deleting/changing the font file from the computer effect the fonts for browsers?


#9

@jsexton

Try checking the settings in Control Panel> Appearance and Personalization > Fonts >Preview or delete fonts

~Drew


#10

Then the issue is not in the browser but at system level. The inconsistent kerning (space between characters) suggests the font cache could be corrupted. Did you try rebooting, this should reload the fonts into the cache?


#11

I would also check to make sure that arial.tff hasn’t been deleted. If you go through the Control Panel> Appearance and Personalization > Fonts >Preview or delete fonts (you may have to change the view to Category), you should be able to see it. If it’s not there, you can reinstall it here. Ariel is generally the default font for Windows. If it is there, try going to Control Panel> Appearance and Personalization > Fonts >Preview or delete fonts and go to ‘Font Settings’ in the left hand panel. You should be able to restore to default from there.

~Drew


#12

I’ve cleared the cache. Rebooted. Checked to see if Arial.ttf is in my fonts settings (it is there). Went to the ‘Font Settings’ in the Control Panel and reset the default. Tried all to no avail.

I greatly appreciate all you guys troubleshooting this issue with me…


#13

Try internet setting under tools. It allows you to set and over ride the ones set by default. That is for IE.


#14

mac7505,

I tried that too in IE. Didn’t work. Thanks anyway…


#15

If you double-click on Arial.ttf in your Fonts folder (Control panel>Fonts), do the font samples displayed look as they should (so that arial hasn’t been overwritten by mistake with another font)?

Anssi


#16

I checked. The Arial font samples display okay so it seems they haven’t been overwritten.


#17

Curiious to know what happens if you do this, in IE:

Press F12
In the new pane on the left at the top is an arrow in angle brackets, on a black background. CLick it
Next to words DOM EXPLORER is a black arrow pointing into a box, click it
Click on any text element on the page, like this comment
On the right of the pane click STYLES at the top
Scroll down til you find the line “14px/19px Helvetica, Arial, sans-serif” and double click on those words
Change the line to read “14px Garamond”, press return

Does all the web page change font? If you don’t have Garamond pick another font on your system


#18

similar thread at rhino’s discourse…

doesn’t seem to be a clear answer/fix in there either.

@codinghorror any ideas since last time around :grey_question:


#19

@jsexton

I apologize for the delay, but I may have actually figured out a fix for this. After doing a little digging, it appears that this site utilizes Google Web Fonts, which cache the fonts from the site on your local computer as temp files. I would suggest two courses of action, if this is the case:

First, delete your temporary files and reload the site. If this doesn’t work, uninstall the helvetica fonts (as it is the primary loaded) on our computer, and reinstall them. Apparently, it looks for the first version of helvetica that is installed on your computer, which seems to be helvetica bold.

Try these, one at a time, and let me know if either fix the problem.

~Drew


#20

You did it wrong then because I just verified it works. You need to follow instructions. The changes are made per instructions under accessibility. You make the font selection under fonts and the set size under accessibility( The caption selection box).You also have to check the over ride boxes depending what you want to change.
Windows also has an Ease of Access Center ( See control panel) to make it easier, I have not check if that over rides IE defaults