Follow Me style Dome deleting itself


I’m trying to create an LED in Sketchup, so I’ve made a cylinder, and across the top of the cylinder, I want to make a hemisphere.

I created a quarter circle from the center of the cylinder base, and tried to use Follow Me to sweep it around the circle. Instead of creating a dome, it’s sweeping away a sector from the cylinder base (and deleting my quarter-circle.

I thought that maybe it was an interaction with the already created shape, so I created another circle on the blue plane, not attached to anything. When I swept with Follow Me, it’s still creating 2d Pac-Man shapes.

Is there a mode I’m missing where I’ve gotten into subtractive follow me instead of additive follow me? Please help.


This is not a bug. It sounds like you are working way too small. Use meters as mm and try again.

Sketchup doesn’t create really tiny faces when edges are less than about a thousandth of an inch.

Which version of SketchUp are you actually using? Your profile indicates SketchUp Pro but you posted in the SketchUp for Web category.

It’s Shop, I’m using the web app, Shop wasn’t an option, and the profile info wasn’t a priority to me when I was setting up an account.

So, making an LED is impossible, then. I really don’t need an LED measured in meters.

You can add Shop to your profile

Maybe not but it helps us know what tools you have available to you when we answer your questions.

I didn’t say it’s impossible. Model it in meters and scale down afterward.


While that works for making blueprints (scaling the image to represent a different measurement) it doesn’t work as well for 3d printing, where the point of making the entire project at 1:1 scale is part of the reason to computer model it.

This component is just for testing that everything fits properly, and isn’t going to ultimately be printed, so I will manage.

As to this not being a bug, it’s a bug. It’s apparently a known bug, as you immediately were able to explain why the software exhibited a behavior other than what a user would expect.

I didn’t just scale the dimensions. The LEDs I drew are actually full size. If I were to export an .stl file for 3D printing the resulting print would be 9.69 mm tall.

Exported .stl uploaded for 3D printing.
Screenshot - 6_18_2020 , 2_30_26 PM

No. It’s not a bug. It’s due to the tolerances set in the software to identify when points are coincident. The software is primarily intended for architectural modeling and as such the tolerances are more than adequate.

The Dave Method works in web too.