Follow me or chamfer on a curved face


#21

Huh. It looks from your gif like your steps are correct, I don’t know why you are getting extra lines off the top of my head. Options:

  1. If erasing the lines, gets you up and running then OK. You can solve the problem of where/why they are being generated separately, I am Mac and know nothing about PC but I hear a lot about having to run the installer as administrator whatever that means and the odd problems that windows 10 can cause.

  2. Redraw the whole thing with @DaveR 's sage advice which would be a great learning experience and give you a chance to fix the clocking of the two circles that we discussed earlier in the post.

  3. If you’re in a bad pinch for time tell us what the chamfer dimensions are and I can post a correct model. This is “giving you a fish” option I would discourage but I have loads of deadlines in my life and am sympathetic.

As far as extensions for solid tools solid inspector and Eneroth Solid Tools are both good places to start.

I do lots of “save as” as my models progress, particularly before big extension operations, that way it’s easy to get back to a good starting place if things go awry. But I use ctrlZ too :smirk:


#22

I am redrawing this using only solid modeling as suggested by DaveR. The chamfer ring is still acting strange…

man, even if i make it a tad bigger, or even exact same size, it still does not want to subtract. I ran into all sorts of issues.

No time crucnh on this. i printed it all ready with out chamfer, because its not needed for the application(as far as i know). But i am wanting to learn this so i have time. haha.


#23

Is that pic from a follow me operation with a cross section of the disk with chamfer already drawn as DaveR suggested? If so then I’m suspecting grafix card or windows problems more and more, especially since you just did an update.

Actually, that there looks more like you subtracted the chamfer with a circle that was slightly clocked so the outside faces did not line up.


#24

it was with the method you showed. I was trying to figure out the follow me on the already completed circle but still trying to figure that out.


#25

Right so It looks like the cutting disc you used was not clocked with your main plate. When you draw the new circle to build the cutting disc make sure you complete it by clicking on one of the nodes of the original circle so the two will line up.

Another way to do this is to remove the chamfer from a cross section before you build the disc with a follow me, this is part of the method @DaveR was suggesting which if you’re going to start from scratch is a good way to go. Notice I’m using a completely disconnected follow me path that I will later erase. But you should be able to make the cutting piece work on your existing model as long as it lines up.


#26

OHHH, just like i would do a revolve for a pulley, a rim, and etc. ok, that makes sense. i keep forgetting about section views and revovles.

Ok, so i did make sure to clock the two circles together, i even viewed the hidden geometry to make sure they lined up correctly. i still get the issue and sometimes, even using the same cutting disc, get differnt out comes. here is another out come. nothing has changed with the disc.

here is a pic. all i did was ctrlz and then retry it.


#27

I think you’re missing a few important things. One of them is the thing @endlessfix refers to as “clocking”. I think you and I talked about this before. When you drag out the radii for circles, you need to do so on axis so that vertices line up. Dragging them out randomly as you seem to have done creates problems as you go forward. In this screen shot you can see that I’ve fixed your plate so that the rib on the bottom is clocked with the outside edge. I’ve also drawn a circle to use for Follow Me for a chamfering profile which is shown selected in blue. It is also clocked properly.

Here’s an edge-on view showing the plate and the chamfering solid after running Follow Me. Notice that the softened edges aligned with the blue axis are aligned throughout.

After positioning the chamfering solid it looks like below. Notice that I made the chamfering solid larger than just the part of the model to get trimmed.

And when I run Eneroth’s Subtract…

The result is a perfect chamfer and the plate is still a solid component.


#28

DaveR, thank you for the explanation and the gifs. i completely understand what you are saying, my SU is having a hard time. Keyboard will randomly stop working in SU,ut work in all other apps. some tools stop working all together. I made sure that the radii of the circle locked and inferred to the endpoint of the other, so that all lines were exactly ontop of each other. Even viewing hidden geometry shows that all lines were all lined up.

I will start a whole new sketch and try again. I am not saying thanks but no thanks and that your all wrong. i really am following exact procedure as you and endlessfix have stated. Maybe i just need to do a clean install again rather than an upgrade from 2015.


#29

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.