Follow me issue. Hollow and not going all the way round a curve


#1

Surely I don’t need to scale up even higher to make this work.


#2


#3

OK. I get it, ALWAYS SCALE UP.


#4

You reversed the faces on your flat object. That might be right if it’s to remain flat, but if you’re then going to make it follow something, all the faces will be reversed. So, don’t reverse faces, have the flat version show you the back color, not the front color. Then the final model will look correct.


#5

Hey guys, another noob here, same problem. I don’t understand the solution “Always scale up”. What does that mean with regard to using follow me? I am rotating a solid 2D face around a vertical (similar to the wine bottle examples), but the faces both end up 'open". Thanks.


#6

SketchUp won’t make very short edges (~.001 in.) and without those edges, faces can’t exist. Those edges can exist but SketchUp won’t make them. The solution is to work at a larger scale when doing things that would generate those tiny edges and faces.

The usual advice is to scale the model up and scale back down. I do it a little differently. I make a component of the small geometry, make a copy and scale the copy up. Then I edit the large copy leveraging the fact that editing one instance edits all the others. When I’m finished, I close and then delete the large copy. Then return to the original which is still sitting where I left it. You can see that here.


#7

Thank you, that was another issues I’ve seen. Curved surfaces generated from circles with lots of segments do odd things. I’ve found that reducing the resolution (number of arcs) of the curved surface fixes them. Is this something that can or will be fixed at some point? Seems like a important limitation.


#8

I don’t know if it will ever be changed. The primary target for SketchUp is architectural drawings and these little tiny detail things don’t come into play there. It’s easy enough to deal with for those of us using it for other things.

I do this quite frequently for things like these:



#9

It’s a limitation of the human mind to comprehend that it is a digital environment and as such scale is actually irrelevant.


#10

So do you know if a part is drawn at say 10x scale and then scaled down to be produced, will that work - or is it a matter of how small the final version is, so it doesn’t matter what the original size is?


#11

It’s difficult to say what scale factor you’ll need. It depends upon how small the short line segments are. 10x might be fine. If not, try 100x.


#12

Yes, that does seem to work. I drew my model in meters and then scaled it down by 0.001. And teh curved follow-me features behaved much better. Now I’m wondering how to change my global units (if possible) because in the scaled down version the default resolution is really large so drawing features is difficult. But thanks for the suggestion about scaling, that is a good trick.


#13

I’m not understanding what you’re asking for. You can change the Units under Window>Model Info>Units.


#14

That’s exactly what I was asking - Thank you.


#15

Oh. OK. You can’t do that. :smiley:

Just kidding.

If you want to make the units change permanent for future models, open a new SketchUp setting, change the units as desired and then use File>Save as Template to create a new template.