Follow me extrusion disappears


#1

Sketchup Make 2014.

I am trying to use follow me to skin a roof on a house model. This is basically a rectangular box with a triangle used for the extrusion. I hold alt to use the automatic method, and it completely extrudes just fine. No matter what I do next, the extrusion disappears at the very next key press. What is the magic here?


#2

It sounds like you are mixing things up. A follow me don’t involve the Alt key. Do you have a screenshot or the model to clarify the problem?


#3

Two follow me methods, manual and automatic. The automatic method is the only way to fly since it doesn’t get caught up on its own geometry if you have a closed loop.
http://help.sketchup.com/en/article/94853

It is a bit touchy in how it behaves. After several more attempts I was able to get the extrusion to ‘stick’ by leaving the cursor over the object instead of moving it away as described.


#4

I’m not too impressed with the “automatic” method.

Instead of manual and automatic, think of it as either pre-select or interactive. Generally pre-select is easier and yields more consistent results. To extrude a profile around a closed shape using pre-select, select the shape, click the Follow Me tool, then click the profile. You could also pre-select the edges bounding the face with the same result.

The Interactive method has you click Follow Me, click the profile, then follow the path with the mouse pointer, pulling the extrusion behind it. Too twitchy, I think.

-Gully


#5
  1. I start with the floorplan outline, and place an upright triangle above this with the appropriate eave overhang.
  2. Select follow me, and hold the alt key before moving the cursor over the triangle to be extruded. Right click and make some small movement with the mouse. I have no idea why it sometimes works and sometimes not. If the mojo is with you it will completely extrude around your outline. If not, it will halt partway or go more than once around, and you will have to try again.
    At this point your cursor is hovering over the model, and you still have the alt key pressed. I have found no consistent way to exit the follow me mode without the extrusion changing. Sometimes you can just right click again, sometimes you can carefully move the cursor off the model and select a different menu item. I have had each of these methods work one time and fail another. If you find a sure-fire method, let me know.
  3. Select all and intersect with model. Erase everything that isn’t a full hip roof. Add dormers as needed. This is way faster than drawing each roof element, or using the manual follow me, but only works for uniform pitch roofs.


#6

OK, I just tried the pre-select and it is way better. It just works and no alt key needed. thanks.


#7

I guess the “automatic method” was brought out in a recent update. It appears that neither @Cotty nor I have previously even heard of it.

-Gully


#8

Could you give us a link to where you read about this mysterious automatic method. If it’s in the help files it needs to be corrected.


#9

It’s here: http://help.sketchup.com/en/article/94853 and it does work but I still prefer preselecting the path before getting the Follow Me tool since it works for both closed and open paths.


#10

Hmm I suspect many of the old help articles were written by someone who never used SU. Thankfully they are being redone. Thanks Dave, must see if it works for me later, do you have to hold your mouth a particular way?


#11

It doesn’t hurt to do so. :smile:


#12

The Follow Me Tool can be used three ways.
@Cotty @Gully_Foyle it’s worked three ways for as far back a I can recall.

Manual
Preselect Path
Follow Me+Alt (Apple key on a Mac)

Try using the Preselect Path method.
Here’s a short video tutorial explaining the three ways to use Follow Me

Follow-Me — SketchUp Video Tutorial



Here’s more from Aidan Chopra about roofs and Follow Me

Complex hip roofs and the Follow Me tool


Using Intersect with Model to make roofs


Making hip roofs


Creating eaves for buildings with pitched roofs