Fog does not show up in scene in Layout

I know the answer must be simple - I am missing something. I created a scene in SU complete with the fog settings, but when I bring the scene into Layout, the fog is not there. This is the first time this has happened. I have had success on two other scenes for another project several months ago, but now I can’t get the fog to display. It looks great in SU but no fog in LO.

Try rendering the viewport in Raster.

Since Nick Sonder uses this technique all of the time, then it MUST work…

Have you saved the particular Scene’s Style to remember its Fog settings [and of course any other Scene-specific settings too] ?

PS: As @DaveR says, also using Raster rendering would also help :confused:

Or Hybrid.

Missing graphical effects in LayOut can also be an indication of faulty OpenGL support in your graphics card. v. 2016 is, again, I understand, more demanding in this respect as version 2015 was.

If, indeed, you were not trying to render fog in Vector, you can try the usual remedies: Upgrade your graphics card driver, or, for a test, uncheck Hardware Acceleration from SketchUp (Window menu>Preferences>OpenGL).

Anssi

Fog works on the raster faces in Hybrid but not on the vector-rendered edges.


fog.pdf (163.3 KB)

It works with raster, but not with hybrid. My graphics card has been updated and I am using SU2013. Thanks for the help and suggestions.

Fog is a raster thing which is why it doesn’t work with vector-rendered entities.

Hi. I am having a similar problem. Fog is not showing up on one of my plans. The SU scene has fog, The layout viewport is rendered in raster setting. Only happening for my second floor plan- Basement, First floor and roof all have fog.

This is my first time trying the Nick Sonder type process. I have SU2017. Thanks

I would like to use Layout (I think) to create transparent “soil” to indicate structure below grade (elevation) . That’s pretty easy to “Fill and Stroke” and change transparency.

But, I would also like to use a Fog(gy) technique to blur the edges of the soil, rather than hard edges from Layout. Possible?

Thanks,
A3_Elevations 2019 DRAFT.layout (2.6 MB)

Not directly in SketchUp and LayOut. You could create an image with some transparency that you insert on a layer above the one your model is on. This is a quickie example.

In this case I drew a face representing the ground in your SketchUp file using the model as a reference for dimensions.


I made the profile a group and put it on a layer that isn’t displayed in the elevation view. I also hid the edges. Then I create a scene from the same camera position as your elevation but with all the other layers turned off. So I have a scene with the elevation but without the ground shape and another showing only the ground shape.

Then I exported an image of the ground scene, added a bit of blur and transparency to the green and made the white pixels entirely transparent. This image was then inserted into LO. Takes longer to describe in text than to actually do.