Flummoxed again - apwll xhwxk (spell check)

Layout Pro 20.0.362 on an iMac running Catalina 10.15.4.

I’m creating a house electrical diagram where I need to use labels such as “ckt” and “gnd”. However, the spell checker always jumps in and changes it to “cat” or “and”. I’d be happy to ground the cat but that’s not what I need right now. I tried resetting the spell check via Edit > Spelling but the only time it is active is if I have a string of text selected. I can turn it on or off for that particular text but then it automatically reverts back to active mode. What’s the secret to turning it off globally? Maybe I need to neuter the cat?

Do you suppose that’s controlled by the operating system? On Windows ckt and gnd get flagged for spelling but there’s no auto-correct going on. Is there a setting in Catalina for spell check that allows you to turn off Auto Correct?

1 Like

As Dave said, it’s controlled by the OS. This isn’t Layout specific. You can turn off autocorrect in System Preferences -> Keyboard -> Text. Or you could add those words to your dictionary. Select a word then right-click on the word in Layout (or any other program that lets you edit text) and choose “Learn Spelling” to add it to your dictionary.

Guys,
Wow, didn’t see that coming, although I probably should have. Yes it is controlled by keyboard preferences. But, I think I’ll just leave it as is (i.e. correction mode) since it’s nice to have when I do e-mails, and forum questions/responses.
Thanks for the quick response.