Flatten faces on object that has smoothed corners

As you can see in the image, when I smooth edges, the smoothed shading also affect the faces that are supposed to be flat (see box 1 - the diagonal line effect). On box 2 I smoothed only the inner edges of the edge curve, but then you get a sharp corner in the intersection between the flat face and the curve.

Is there any way to get a better result doing this?

I know in 3ds max there is a script for flattening surfaces that come from etc. sketchup models, but I dont want to learn 3ds max, neither do I own it.


Yes, its on that cube as well. I am using RoundCorner plugin, its not a problem with the plugin but how sketchup does this.

Its not very noticable. But if you bring your object into say Unity you will notice that the faces does not recieve light like a flat surface should, with some textures it is not noticable but with others and in the correct light settings it is noticable, cause the face acts to light as if it is a curved object.

Are you hiding the edges at the limits of the radius? Or are they softened?

On box 1 they are hidden, on box 2 the outer edges are not hidden or softened, so here the face is recieve lights and reflections as a flat surface should.

But in box 2, if you zoom in closely you will notice that when not smoothing the outer edge you get a hard edge, wich looks unatural up close.

I guess i could maybe avoid it by doubling the numer of faces on my curve.

You could try more faces on the curves but I think you’ll find that using hidden edges instead of softened at the perimeter of the flat areas will give in better results.

FWIW the large faces are flat. It’s the rendering that makes them look not flat.

Changing the lighting could also help.