Fixing issues in object for 3D printing - not able to find the mistakes


I am new to SketchUp, so sorry if this issue is obvious! I’ve been drawing a container with two reservoirs attached via pipes (.skp file is attached), and when I open it in Cura, the time to print is weird and suggests that there’s some issue.

I downloaded both Solid Inspector and Solid Inspector2 but am not able to figure out what the issues actually are. The latter keeps automatically closing all the open holes I have (which I don’t want- I need those holes on top!) and the former extension basically marks every point where two objects are joined.
It looks like there’s something I’m not aware of with regards to actually “joining” solid objects, although I was drawing each new part attached to the earlier parts, so I don’t know how the issue occurred or how to fix it.

I would really appreciate any guidance or suggestions on this. I’ve tried grouping (it didn’t fix the issue), selecting each part and using “intersect faces” with the next part, etc… nothing has worked so far :frowning:

Thank you in advance for helping a newbie :slight_smile:

Reservoir version.skp (408.8 KB)

Faces in SketchUp have no thickness. Your reservoirs need to have some wall thickness to be considered solid and printable. The faces of the pipes are reversed and need to be corrected too. There are also internal faces and edges in the elbows of the pipes that will prevent those areas from being printable.

Screenshot - 1_19_2018 , 10_32_24 PM

I don’t know if the dimensions are exactly as you’d want them but this shows how it should look as a solid. Obviously I’ve made a section to show the internal bits. The reservoirs have wall thickness and there’s no internal faces. And the faces are all correctly oriented.


Firstly, thank you so much for taking the time to reply!

I have a question about this issue of the faces having no thickness - initially, when I had drawn just the rectangle with the hole through the center, I used the push/pull function to turn it into what looked like a solid. Cura did not seem to have a problem with just that piece, and I was able to 3D print. However, in the above version with pipes, etc, I continued to make all the pieces the same way - by drawing the faces and then pulling them. Why is it that the original rectangle could be 3D printed/considered a “solid”, while this couldn’t?

As for the images you have attached - they are beautiful and really explain my issue; thank you so much! A couple newbie questions:

  1. How can I tell if the faces are inside out? What caused them to be so, and how can I fix that?
  2. How do I add thicknesses to the faces and generate something similar to your final image?

Thank you so much!

Using your earlier images and the offset tool, I got this far (attached), but it still doesn’t say “solid” when I turn it into a component and view entity info.
I also cannot figure out how you generated the cylinder of some thickness for the reservoir, and how you were able to connect it so neatly to the opening. Could you perhaps guide me on how to do that as well?
Thank you!3Dattemptagain.skp|attachment (421.7 KB)

In order to be printable, the geometry must be what SketchUp calls “solid”. In simple terms a shape is solid when all of it’s edges are shared by exactly two faces. No more and no less. Your model exhibits many places where this requirement is not satisfied. The opening at the top of the reservoir consists of edges that are only shared by a single face. The same applies to the internal faces in the elbow of the pipe.

On the other hand, where the outer surface of the pipe exits the reservoirs, there are edges shared with three faces. Also at the point where the inner surface of the pipe meets the block.

Compare that to mine.

Face orientation is indicated by color. Blue is the back face color. You shouldn’t see the back faces when the object is 3D. Notice how in my version the back faces are all on the inside.

I drew a cross section profile of the reservoir and extruded it around a circle using Follow Me. I drew the profile so that the hole would be formed at the top as well as at the bottom. For the pipe, I drew an L-shaped path from the bottom of the reservoir and then drew a circle on the bottom of the reservoir around the bottom hole making a sort of flat donut. I then used Follow Me to extrude the donut along the L-shaped path.

It doesn’t meet the definition of solid.

There are internal faces at the end of the block and along the length of the passage through the block.

In the vicinity of the central hole there are edges shared by more than two faces as well as at the top and bottom of the block. Eliminating the larger diameter tube running throught the block would fix that. The vertical lines crossing the openings in the tube aren’t shared by any faces so they have to go as well.

When you clean up all of that stuff and make sure that every edge is shared by exactly two faces, you’ll be all set.

1 Like

Here’s a rough gif on how it can be put together.

1 Like

Some of us have difficulty noticing the difference between blue and white on our screens. Fortunately, SketchUp allows us to change the colors used for front and back faces. I use red for my back faces, here’s how (from the styles section in the Default tab - if you haven’t customized your UI!):

Yes. I know. I’ve used green for my back color for more than a dozen years.
Screenshot - 1_20_2018 , 10_50_25 AM

Wow, thank you so much for all the helpstillnotworking.skp|attachment (746.0 KB)

Unfortunately, even with all of this, I am still getting something wrong - Cura isn’t able to see this as a solid object (attached). I’m so sorry for this – is there still a hole somewhere? I made the object in a nearly identical way to Box’s gif (thank you so much for this!), but somehow still managed to do something wrong I guess.
I would really appreciate it if someone might be able to tell me where the extra hole/face/unknown object is.

You already mentioned that you have Solid Inspector. Use it and you’ll see the internal faces. If you let it fix the model, it is then solid. This may not be what you want though as you have very thick walls on your two reservoirs.

These screenshots were taken with X-ray mode on to see the internal faces easier.

There’s still a segmented circle just above the highlighted area(@Box deleted this in his GIF ), but Solid Inspector2 and SketchUp see it as a solid now, so hopefully your printer software will too.

I used Solid Inspector and it fixed the internal faces - SketchUp is ok with it as a solid now, but Cura still doesn’t understand it.

Looks like you have the scale wrong for Cura. That checkerboard is quite large.

I must admit I used a weld plugin on those rings to make the face delete with one click. Pure force of habit. If you watch carefully you will see them flash red as I’m reaching for the circle tool. That was Fredo’s Curvisard weld on a shortcut key.

It worked!! You were right - the scale was off for Cura. Thank you all so much for the help and advice!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.