[Fixed] - Sketchup 2019 keeps Crashing

Hi Guys,

My Sketchup keeps crashing. I can’t even copy/paste anything before it crashes… I really need to keep working ony my documents. Any ideas ?

Thanks !

First thing to check is that SketchUp was installed correctly. Find the installer or download it fresh from sketchup.com/download/all, right click on it and choose Run as administrator. When the options appear, choose Repair.

Hello Dave !

Thank you for replying so quickly. I did try the Repair functionality with admin privilegies. Did not change anything.

What happen is after I try to turn some elements by 90°it crashes.
It also crashes just when I open the file, select all, use CTRL+C to copy = automatic crash

Does that mean you logged into Windows as admin or you right clicked on the downloaded installer and selected Run as administrator?

Did this work before and now it doesn’t?

Is it possible you have some extension causing a conflict? Maybe Vray?

Can you share the .skp file so we can see what you are working with and try it to see if we get the same results?

And what does Crash mean for you?
Does it Bugsplat?
Freeze?
Shutdown without warning?

1 Like

I am administrator of my machine, I right clicked it and lunched it with admin privilegies.

For now it is a simple draft.
I never had any issues before. I did a lot of project with Sketchup before and everything was working perfectly.

What I means by Crash is that the software just leaves. I have to restart it after. No warning message or error message. It just crashed. Shut down.

3D de trucks et équipements.skp (1.7 MB)

So what has changed on your computer since it worked? Graphics driver updates? A new extension?

There is an issue with the model, shuts down without warning for me too,

Nope Nothing. I was working on it for an hour and out of nowhere this happened =/

Update, so I deleted the orange boxes and looks like the issues is gone… Weird. Can we know what was wrong with them ?

Your model opened fine here and I can’t see anything wrong.

Try rotating the orange roof component.

I can’t find a reason, where did they come from?
Did you import them or model them?

No no fully modeled on the software. I mean they are really basic…

1 Like

Ok, that made SketchUp unresponsive and I had to force-quit it.

I just redid the orange components and now it works well. Weird !

I managed to narrow the problem down to that particular group. It’s possible to go into the group, draw something new, delete the old stuff, and still the crash when copying happens. If you select the rest of the model and delete that, the crash doesn’t happen. Trying a move/copy also crashes.

I will see if there is a known issue, and add this as a test file.