File Format unrecongnizable


#1

I recently deleted by mistake a sketchup model and was able to recoup it through a file recovery system. The software shows that no clustors of the file were overwritten and I restored it without a problem. The file is visible in the preview of the dialog box when I click to select it for opening in sketchup but when I try to open the model, it say file format unrecognizable. It is a .skp file and was restored as such with no modifications. Any idea on how or if I can make readable this file. (note: I also deleted and restored the autosave version but this gives the same error when trying to open or rename from skb to skp. I also tried importing the file as a sketchup model and again, it recognizes it in the little dialog box, but give the same error message when attempting to open it.

Any ideas much appreciated…
david


#2

It sounds to me as if the thumbnail JPG was recovered uncorrupted so Windows could read and display it. The SKP and SKB files weren’t recovered correctly by the file recovery system, though. I’m not sure there’s much to be done with it but I think it’s a job for @DanRathbun. I hope he can help you out.


#3

you can check if the .SKP is a true SketchUp file and not something with a renamed file extension by opening the file in a text editor. A SU file would show “SketchUp” in at the beginning of the file header whereas e.g. a JPEG shows “JFIF”.