Feature Request - scale radially about component origin

I’m having great trouble scaling irregular not-quite-round objects to a particular larger or smaller size.

I’m having to scale about centre by a numerical factor, since scaling to a new given size using the diagonal scale tool handle doesn’t work usefully for this purpose - it makes the diagonal dimension the length you specify, and I don’t know that in advance. And although I think I’ve calculated the scale factor correctly, it still doesn’t come out to the size I wanted. Maybe the scale tool only uses a small number of significant digits? My scale factor is often very little greater or smaller than one, sometimes with only one or even two zeros (or 9s for a scale down) before the first significant digit after the decimal point, then several more digits after that.

If I could scale radially about the origin, which isn’t usually at the ‘centre’ of the bounding box, to a finished radial measurement on any one axis, life would be a lot easier!

[Afterthought - do any of Fredo’s extensions do radial scaling? I’m not familiar enough with them to know.]

I know of that, but unfortunately at the new scaled size, I don’t know the three individual dimensions.

But (DOH!) using the tape measure tool to scale one component should do the trick, I thought overnight.

I’ll try it now…

Well, in principle, it works. But scaling that one component is scaling something else too, which it shouldn’t be. And when I try to scale that back down again, it complains that it was loaded from an external file and won’t scale.

I’ll have to check the structure of the model again. A few edges are disappearing too. Must have got a tag associated with them by accident (though I did do some by design, knowingly).

At least I can get one component to scale to a size with the tape measure tool.

PS. I’ve done it now by copying the component into a new file, using the tape measure tool to set its new size, then pasting it back into the original file. Cleaned up the edges tags at the same time, too.

So finally all straightened out.

That appears to do just what I want, and has left the component origin in the same place.

If you open the component for editing and scale the geometry with the Tape Measure tool, you won’t modify the rest of the model. If you are scaling without opening the component, remember to scale it’s definition.

That’s what I thought should happen, but I must have had another component inside, tagged with a tag that wasn’t visible, which scaled with the parent, when I didn’t want it to.

At least, I think that’s what happened.

Thanks for the clarification.

If you know one, pick the corresponding grip and hold ‘Shift’ for scaling uniform.

If you got a finger left, (I alway’s ask woodworkers…) hit the ‘About centre modifier’ , too

1 Like

Thanks. I should perhaps have known about the Shift key modifier, but hadn’t actually seen that before. Thanks.

1 Like

I had thought that the Tape Measure tool used for scaling offered to scale only the selected component. But it doesn’t. It only offers the choice to scale the whole model.

Is that expected behaviour?

I thought I’d remembered that it did. Is it a matter of pressing an option modifier key?

If you go into the component / group (edit component/group ) you will be able to resize the active context group or component.

1 Like

AHA! I knew I had done before - forgot how. Thanks for the reminder.

It would also make sense if it worked the way I tried - on a selected component only, NOT opened for editing.

I found myself in the same situation a couple days ago thinking, “I know I’ve done this before.”