What is an ideal way to re-size from meters to mm?


#1

I’m surprised I’m having difficulty with this but I can’t seem to find the right order of scaling if I want to scale down a component by multiplying a factor.

I built my model in meters. Now that it’s complete, I want the model to be mm for 3d printing. So parts that are 17m in sketchup will be scaled down to 17mm.

In hindsight, perhaps I should have built the model with a template in mm, and simply scaled up a copy of it. But I didn’t learn about this trick from DaveR until after I started the template. I thought it would be no issue if I built it in meters and just scaled the model by a percentage.

Can’t I just multiply my scale by a factor of .001 to change it from meters to mm? I tried opening the component, then scaling, but it won’t let me place “* .001”.

What is the best method for changing my model from meters to mm?

thank you,
Rick


#2

Leave out the asterisk.
Grab the scale handle and drag then type 0.001 and hit enter.


#3

Oh, I guess I over thought the process, LOL

I was trying to type the asterisk the whole time.

thanks,

I’m so bad about working harder than I need to.


#4

tape measure also can be helpful.

http://help.sketchup.com/en/article/95006

watch out though. if the model includes a lot of groups and components that are scaled that much, you can face clipping issue. if you do scale them, make sure you set them as “scale definition”


#5

Yeah, thanks.

I only use the tape measure tool for resizing if I want to chose the size of something by using one dimension as the longest dimension.

So I do like the tape measure tool for resizing parts of a model. But for a completed component with many parts. To have perfect 17m to 17mm conversion, the only way to do it right is factor of .001.

I think from now on I may just use a template of mm and just blow up a copy of what I’m working on. But I guess it does not matter.

Thanks for all the help good people.


#6

Actually Rick, if you open the component for editing and use the tape to measure the 17m and type 17mm it will resize the whole component exactly.


#7

I was about to say the same thing, @Box beat me to it. :smiley:


#8

Ah, I see.

Thank you, gentlemen. I will use that as well then. Everything is working fine so far.

Good day to you,

Rick


#9

I’m still having problems.

I was able to make my model .001 times smaller. And I was able to change “model entity” to report in mm now. So my model does read 17mm.

But when I export .STL from sketchup, and try to upload to shapeways. Shapeways is saying it’s 17meters, not mm.

So is the Meters template I originally used forcing Shapeways to think it’s all in meters?
What should I do now, please?


#10

STL files do not contain information about their units; it is up to the program using them to interpret the file correctly. I do not know Shapeways, so I don’t know whether it offers an option to determine input units, but clearly in your file it is assuming 1 unit in the file is 1 meter.


#11

Yep, my suspicion was correct about the template being the issue between sketchup and shapeways.

Even though I sized my model to 17mm on the first template, shapeways kept thinking the model was 17 meters.

I simply copied the model from the old template, and pasted into a new mm template, and now shapeways can read it correctly.

Strange but no problem now. So from now on, I will just build in the mm template and simply blow up copies of models for working on them instead of building them in meters to begin with.

I’m guessing that if you pick meters as a template and begin building there, the boundary box is perhaps forcing it to always be read as meters? That’s my best guess.


#12

if i do remember correctly, shapeways will pick off your model units.

You can find your units under Model info -> Units


#13

Just because there are many ways to do the same thing: If you use the scale, you have the option of typing in the units rather than a factor (eg scale one axis and type in 17mm, then it will make that size 17mm) Or you could make a box that’s 17mm and use it to snap the scale handles to.


#14

Once scaled to 17 mm you need to right click on the component and select Scale Definition. If you insert another instance of the component into the model it will be 17m. Scaling a component doesn’t change the raw geometry of the component, only it’s relative size in the model.
It can also make a difference what units you put in the .stl export dialog.


#15

Oh, that’s very interesting and good to know, thanks Box.

Sounds like that was the issue for me.