Fade / hide model Shortcut


Hi there, my 1st post (I think!)…
Is there a shortcut or button option for the ‘hide/ fade rest of model/ components’ -ideally I’d have it on its own pallette/tool?
I use it all the time and hate how it has that huge model info box that often disappears/ get under other tools


Go to Window/Preferences/Shortcuts and set it to your key of choice.


I have Shift-H set as a shortcut to do this.




I know how to assign shortcuts, which will just bring the same box up. I’d rather it had its own button or shortcut that went straight into the command itself


Assign the shortcut to the function. I’ve done that here:



I don’t understand the “or shortcut” in your post, but anyway to get the command onto a Toolbar button you would have to do some Ruby coding.


Assign a shortcut to each function.
With that, you can toggle them on/off at any time.
View commands are ‘transparent’.
That is, they do not interrupt current tool operations and no dialog box appears.



Didn’t realise the command appeared down there as well as ‘window/model info’…thank you !!


See these tutorials…


On the Mac, if you want to use the ‘H’ you can’t use CMD-H because it is OS wide used as hide the app. The ‘H’ it self is used as the ‘Hand’ pointer. Not in Windows?
You have to use Ctrl-H or Alt-H or in conjunction the shift key. However when using the shift key with any control key or not it always shows a plus/minus sign. Bug or…?


I use U to toggle rest of model visibility and I to toggle similar component. Don’t know exactly why I picked them but probably because they were two free keys next to each other. These are probably some of my most used shortcuts (after actual tools). I use these way more than hiding entities or toggle hidden geometry.


I use ctrl-G and option-G on my Mac for “hide rest of model” and “hide similar components”. I did that because G (or shift-command-G) and command-G are already associated with “create component” and “create group”. These seemed like related commands, as opposed to “H” which as you note invokes the move (aka “Hand”) Tool.

On the Mac, most command-key chords are pre-assigned to menu items or OS functions and can’t be used for keyboard shortcuts in SketchUp. They are hard-compiled when the code is built, and are intercepted by the OS and menu system before they ever reach the keyboard shortcut system.

The handling of the shift key depends on the currently active Tool. On many Tools it is the modifier key to vary the action of the Tool. That usage takes priority over your keyboard shortcut, so result can vary depending on what you are doing. So a quirk, but not a bug.


I tend to use the orbit key and hold down the shift key to pan so I never used the h key. I chose to re assign the h key to toggle hide.


Me, too.