Extruding a complete path with the follow me tool

I’ve been building window components in sketchup lately by taking the manufacturer details and simplifying them into parts, then extruding each part around a rectangle using the follow me tool. When I finish, it looks great, but the tool is dividing all of the lines where I place the profile to be extruded. I want each edge to be one single line, but on the edge where i initially place my profile, the lines below and above where that profile was are split and can’t be edited together. When I try to move edges to change the size of the window, these lines act separately. I’ve attached one of the models I’m having trouble with. Everything works great until i try to shorten it to a certain point. If you turn on hidden lines (you have to to edit the model anyways) you can see what I’m talking about. has anybody else had any luck getting sketchup to follow a closed path and join the lines on either side of the starting point?

Menck Fixed Picture.skp (194.9 KB)

Hi brhoads, hi folks.

See attached SU file for ideas.

Make sure that you use the quick procedure:

1 - Double click the rectangle to select the path to be used by the Follow Me tool;

2 - Select the Follow Me tool;

3 - Click on the profile.

Best regards.


Profile position to avoid edge split with Follow Me.skp (22.8 KB)

that makes a lot of sense, thanks for the help. I’ll try it out and see if that fixes my problem