Extensions not showing in 2019 Pro

Hi, hopefully, someone can help me with what I would imagine is a simple fix that I seem to be missing…

I have been using SketchUp for a few years now and know the basics, recently I have started to explore more of what could be done which led me to extensions.

I have installed extensions via the ‘Extensions Warehouse’ which seem to be installed and are enabled, however when I try to access them and add to the toolbar they are nowhere to be seen.

I have also tried downloading the file onto a folder on my PC but when I go to install it the file is not saved in an rbz format and won’t open.

I’m sure the answer is simple but after watching numerous videos I still can’t seem to find the solution, any help would be appreciated,

Keith

It would help to know what extensions you have tried to install.
Some may not be compatible with the SU2019, some may need other helper extensions to be installed as well. But without knowing we are only able to guess.

When you install SketchUp 2019, it creates a separate installation (since it is a major version), so the Plugins folder won’t have any of your previous extensions except of SketchUp’s default extensions.
If I understood right, you did then install extensions from Extension Warehouse (Window → Extension Warehouse). Where an extension appears in the user interface (and whether it has toolbars or menu items) depends on the individual extension. Since you know your extensions already from before, I assume those should have created toolbars.

  • Have you restarted SketchUp after installing the extensions (should not be necessary, but some only load fully after restart)?
  • Are you sure your extension settings don’t prevent them from loading?
  • After downloading, extensions should appear in .rbz format. You install .rbz files through SketchUp → Window → Extension Manager, they should then be unpacked and the contained files copied to the Plugins folder. If you use Windows, you cannot double-click .rbz files because it doesn’t recognize them as a known format (or that they are actually zip files).

Hi, the extension is Enscape, I think this may be the issue as I have just noticed that it may not be compatible in Pro 2019?

Hi, I have set the extensions settings to ‘unrestricted’ however I think that the issue may be the extension I am trying to use. I am trying to use Enscape and after looking into this further it may not be compatible. There are other extensions in there…sandbox…Trimble connect etc and these are now working fine, it just seems to be the Enscape one.

Do you know if there is anything that can be done to get this working on Pro 2019 or will I need to go back to 2018?

Thanks,

Keith

Have you checked Enscape’s website or contacted their support with regards to the problem?

Hi, yes, just done and waiting for a response, thanks

Why wait?

Brilliant…thank you, it is now working. Really appreciate the advice from all of you, thanks again

1 Like

This is now working, thanks for the help everyone,

Keith

To be honest, I’m still not sure what the technical difference is between a plugin and an extension, but there are some extensions that can only be accessed through the dropdown menus as they do not all come with icons for the toolbar.

@whiterabbitdesigncompany
All Ruby scripts are ‘Plugins’.
These create various functions and tools to enhance SketchUp.
All Plugins load as SketchUp starts.
Some Plugins are quite simple, others more complex…
Some Plugins are created by there authors as ‘Extensions’ - often these are the more complex ones.
This means the Extension can be set to be enabled or disabled as SketchUp starts - using the Extension Manager.
The EW only deals in Extensions, but the SketchUcation PluginStore has Extensions AND several Plugins too…
Almost all Extensions [and the PluginStore’s Plugins] are provided prepackaged in RBZ archives, which can be installed into the User’s Plugins folder, using the Extension Manager > Install… tool
An RBZ is a re-suffixed ZIP file.
Typically the RBZ contains an RB file which loads as SketchUp starts, and a subfolder of the same name, which contains the other files needed for the RB file to load its functions and tools.
The Ruby files inside that folder can be RB or encrypted RBS or RBE files: the RBE being most crack-proof but only suitable for >v2015 users.
The folder might also include image files for toolbar buttons, html/css/js files to make special dialogs etc.
In recent versions SketchUp also checks for a ‘signature’ for the files in the subfolder - in two added files.
These are added in a process at a SketchUp portal, accessible to bona fide authors and also during EW submissions. Older RBZ files may not have valid ‘signatures’ and therefore their contents will not load unless the Extensions Loading Policy is set to ‘Unrestricted’ - however, this is not dangerous, provided that you got the RBZ from a reputable source like EW or the PluginStore, or perhaps directly from a developers own web-site.
Note that some very complex Extensions do not load via the Extension Manager but use a custom ‘installer’ which might install into the Plugins folder or elsewhere depending on the toolset…
When a Plugin loads it creates various coded ‘commands’ which the user then invokes in numerous ways…
Here they are, simplest first…

  • The user types a command in the Ruby Console to run the code.
  • The user chooses a command from a menu item [the most common method] - note that although most appear under the ‘Extensions’ menu [called ‘Plugins’ in earlier versions], the author can choose to include the commands under any menu heading. There might also be a submenu containing several related commands - this might be named after the tool or the author. Such menu items can be assigned to Shortcuts under Preferences.
  • The user must run the command from a right-click context-menu item, or submenu item. Often this only appears [or is enabled] when there’s a suitable selection.
  • The user can activate the tool’s Toolbar, and then clicking on a button runs the command.
  • Depending on the tool there may be a combination of menu, context-menu and toolbar operations to use the tool…

Hope that clarifies things !

3 Likes

Same type of qu as above.

Some extensions installed and running fine - Weld, Cleanup, Eneroth Flatten to Plane

Some extensions - Bezier Tool, Bezier Surface and Fredo6 Round Corner not showing in SK19./ Extensions tab

Extensions have ‘unrestricted access’
All versions are up to date and are meant to be SK19 compatible
All are showing under SK19/ Windows/ Extensions manager as present and enabled.
Have closed and re-opened SK19 (several times) plus numerous reboots.
Running W10 via Bootcamp on Mac (pl don’t ask cos I don’t know either!).
Beginner (but at age 70 that sounds a bit stupid - is their a ‘senile’ level?).
All look to be nicely embedded under 'Users/ Me/ Appdata/ Roaming/ Sketchup/ Sketchup2019/ Sketchup/ Plugins.

Thanks - Errol

Have you tried looking at Tools > Fredo6 Collection as well?
ext-02

1 Like

DoH. - Oops.

Defo place me in the ‘senile’ category.

Thanks ever so - Errol

Got a bit happy too soon. Fredo6/ Roundcorner was there and did the job nicely.

Another Fredo - Bezier Spline isn’t showing. Nor are Bezier Surface, Bezier Tool, Bezier Surface nor Uniform Rational B-Spline Curve (looking under SK Tools and SK Extensions tabs this time!).

All showing as installed and enabled via SK/ Windows/ Extension Manager.

Any ideas where I could have hid them please?

Thanks again - Errol

Did you install Lib_Fredo6? This is a library of scripts common to many of Fredo6’s extension that must also be installed for many of his tools to work.

Look at Draw > Bezierspline curves and View > Toolbars

1 Like

Yes. Did that thanks Dave. It shows under SK Tools tab, and holds Fredo6 Roundcorner.

You’ve done it again Mihai.

Thought all extensions would come up under, well, Extensions, (then ‘Tools’ as well) but…

Nup.

Thanks again - more toys to play with tonight - Errol