Extensions Load Error

Hello SU’ers
Out of the bleu my extensions won’t load anymore.
I have tried to repair SU (twice) to no avail.
I wouldn’t mind to reinstall SU but loose a lot of my seats in a good few Extensions, like Fredo’s
Curic’s and more. And that’s a lot of hassle to Re-Activate again as you may know.
I leave you some screen shots of the Load Errors.
For some reason all extension errors in this message ending with a Hebrew text
,יום הזה, בסביבות 9 בבוקר, הוא עד , or ?? ,This day, around 9 am, is a witness, ??
**can you please give me a explanation for this, thanks
**
Thanks Makki

I’m using Win 10 pro
SU Pro 2021 Vers. 21.1.332 64-bit
Processor i7 920 @ 2.67GHz
Ram 24.0 GB
NVIDEA GeForce GTX1060 6GB
Ashampoo_Snap_Friday 28 October 2022_09h44m42s_001_
SU Load Error 2

Have you installed new extensions lately?
How about disabling all extensions and then re-enabling them one by one until the errors reappear?

2 Likes

Hello Anssi
No i have not installed any extensions or other software lately.
I don’t know what happend, I had ,Load errors, before but not like this one.
I have now reinstalled a clean sketchup as i need to continue work and will see
if one of the extensions is going to give problems (which i doubt ) .
But still like to know if there are other reasons and solutions to have solved this.

(and Ps. I did double post it . Because i thought that i was in the wrong section,Sorry :slight_smile:

Is this perhaps a Ruby developer’s way of telling you about an expired license or something? As it is not gibberish it must be something someone put there on purpose.
What is that “!curic_recall_command_loader.rb”?

No … these are LoadErrors … actually SyntaxErrors occurring during the load cycle.

They indicate (to me at first glance) that there is some kind of encoding error happening with the evaluation of the Ruby code files.

It looks as Curic’s recall command extension is at the top of the list because it has a "!" prefixing the registrar file name.

  • I would suggest you start by switching off this Curic extension (or drag the registrar file into a temporary folder.

I do this often in testing. I make a subfolder in “Plugins” and name it “Plugins_OFF” and drag-move any extension registrar files (or any other script files) that I need to not load into this “OFF” folder.


It might be possible that one of the plugin developers thought that they could change the default internal or default external Encoding for all Ruby files. Changing it to anything other than UTF-8 will be problematic.

Or perhaps there has been a system change on your computer ?
Do you know what your system character encoding is ? Is it one of the Hebrew encodings ?

1 Like

See my post above …

Thanks for reply Dan
I will try to solve this problem in future by switching off the one on top (and down) in the load error message and moving them in a suggested named subfolder. Sound like a save plan to me.
Yes i think it has something to do with with a change in the computer because two days ago it was all fine.
But still confused about the Hebrew text as it makes no sense to me.
thanks

You’re in Eire - so it’s unlikely your computer has reset to ‘Hebrew’ or a weird location
However, check that out…
I suspect that the error is compiling from !Curic… 's extension, although I see my own code ‘…divide_angle’ is also implicated…
I fail to see why !
Disable the first extension’s RB that’s reported and see what happens after a restart…

1 Like

Hello Tig
Thanks for reply, Everything still in English.
Curic maybe gave this problem or a windows start up, but I will follow Dan Rathbun’s advice for the future.
I have reinstalled all and seems to be ok for now. Have solve to reinstall the seeds
from some plugins as some of them where full.

I’m seeing the same problem suddenly with all my extensions on load. I don’t have !Curic as one of my extensions. I don’t seem to see a way to reinstall automatically, It looks like I have to uninstall and then reinstall. I tried reinstalling Sketchup Pro and this did not help.

Share the exact load error messages you are seeing.

Did you recently upgrade to Sketchup 2022?

When you reinstalled SketchUp did you reinstall it correctly? That requires right clicking on the installer and choosing Run as administrator?

How did you install the extensions? Did you just copy and paste them from an older version? Or did you do something else?

1 Like